Started Disk Manager Error on boot up after install


#1

Hi all
Im new to PureOS but not to Linux as such. I love the simplicty and stability of PureOS along with Bunsenlabs I rate them to be the two best Debian distros out there. I managed to install Pure onto an old Dell i3 desktop for office use and its one of the best distros Ive used in years.
I went ahead tried it on an Asus all in one PC but I seem to be having problems with getting it to boot after installing onto the Asus? It worked without problems when I tried it out on a USB live stick, no problems at all so I went ahead and installed it but upon first boot I cannot get past the “Start Display Manager” part of the boot process? I searched the forum post and I tried this solution below

https://tracker.pureos.net/w/troubleshooting/broken_upgrade/

but it didnt change anything. I dont quite understand what the problem is? As i say PureOS didnt have any problem in running in live mode on the Asus, no glitches at all very smooth and stable so why would it get stuck in the boot process? (I also have Bunsenlabs on the same PC so its a dual boot PC)
Any help very much appreciated as I’d really like to get Pure onto another PC at home for the kids to be able to use.
thanks in advance


#2


Ive uploaded an image to illustrate the problem I came across on first boot and subsequent boots of installation, notice that now the last line reads “GNOME Display Manager” ?! .Thanks for any enlightenment on the matter.


#3

Whenever I’ve run into that (on other distros) it was a graphics issue. They didn’t like my ryzen 3rd gen. I would suggest you drop to a terminal and either run some updates or install a non free driver. I can’t remember the TTY shortcut off the top of my head, I’ll check real quick.


#4

Ctrl+alt+F2 I believe.


#5

Cheers for the input Gavaudan, from the command line using Ctrl +Alt + F2 Ive run the sudo upgrade and update commands and rebooted but to no avail, i think it might be the video driver (as i see part of the grey graphical PureOS loading progress bar then screen goes black…)
what is the best command line to use if thats the case, i.e. to update graphics driver?! thanks for any more info, im not a newbie but not an expert either so linux is a learning curve at the moment for me!


#6


So this is really bizarre now,I tried to reboot again to try and get to a command line and its actually advanced from being stuck at the GNOME Display Manager bit to now the Network Manager Script Dispatcher Service line…surely any conflicts like this would have been picked up when I tried PureOS at great lengths during the Live USB stage before I installed?! Im quite perplexed as underneath the hood of Pure is Debian which Ive never had a problem with i.e. I also have Bunsenlabs installed on same PC. Thanks to anyone for any more input its gratefully received!


#7

If it was my computer, I’d add the non free repo to your sources.list, but I don’t know what that is off the top of my head. I know its mentioned here in the forums somewhere, along with instructions. I’m at work currently or I’d give you more detail. After you do that run a sudo apt update and sudo apt full-upgrade. If that doesn’t work, more investigation will be needed (at least by me, it’s been a while since I’ve had this problem on a Debian OS).

Also, for future reference, “it works on the live USB, so it’ll work on installation” is not necessarily a true statement. Running live uses (generally) bare minimum so you can work with the OS. When installing, it attempts to configure itself to your hardware, but as you can see, it doesn’t always work out.


#8

Totally know what youre saying with regard to "it works on the live USB, so it’ll work on installation” its just that ive always found Debian to be stable no matter what machine i put it on and never had issues on first boot…but then this PC is an all in one so I reckon its got something to do with the Radeon graphics driver installation…see latest image. Am I right in thinking that if I need a non free driver then Im not going to be able to install it on PureOS, as stated the Wiki “Check if the firmware-linux-free package is installed, install it if not. If the device requires non-free/proprietary binary drivers/firmware, it won’t work in PureOS.”

Any more input much appreciated if you get the time when youre back from work. I’m no expert when it comes to Linux but willing give anything a try in order to learn new things about it.
Chat later I hope. All the best. Foi


#9

since that is closed-hardware (the Asus All-in-one you say you installed on) i’d be easier for you to just put > https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/weekly-live-builds/amd64/iso-hybrid/

or > https://releases.ubuntu.com/20.04/ubuntu-20.04-desktop-amd64.iso.torrent
but you’d have to figure out how to verify the image

or > https://torrent.fedoraproject.org/

or > https://manjaro.org/downloads/official/architect/

or > https://pop.system76.com/
pop is a little buggy for me and the custom theaming applied by sys76 is not very lisible (that light blue needs to go from GNOME-disks) but for hybrid-graphics it just-works out-of-the-box

that beeing said you can ALSO stick to our beloved PureOS and MAIM it into a franken-non-free-debian but that would take some more investment on your part …

this is why we need open-hardware guys :slight_smile:


#10

Thanks for the input reC its much appreciated, I’ve tried most of those distros you mentioned and many others, but have found the debian based distros like Antix, Q4OS and Bunsenlabs the most stable and simply work out of the box after installing. The Asus all in one also has had Bunsenlabs Helium installed on it for over a year now without any problems. I’d really like to stick to PureOS as it worked really well and smooth when I tried it out on the Live USB stick. Would it be a question of just adding the “firmware-linux-free package” to the sources list or would that already there on PureOS post installation? And if not, is it easy to add the “non free contrib” to sources list and then upgrade and update? Would that resolve the issue with the Radeon card? I wouldn’t want a franken non free PureOS system in any case, would just love to see it run as smooth as when i tried out the Live USB.


#11

Have a look here:

https://linuxconfig.org/how-to-install-the-latest-amd-drivers-on-debian-10-buster


#12

Thanks for the link, I did try yesterday to add http://deb.debian.org/debian/ buster main non-free contrib etc…to the /etc/apt/sources.list using the command line but upon but it wouldnt let me save it stating it was locked? Is there a specific guide of editing the sources list in PureOS from the command line? I know this goes against the whole ethos of PureOS of using non free software but I just want to get the graphics driver installed so i can start using Pure…thanks to anyone for any more help, im determined to get Pure going on this PC!


#13

If it said the file was locked then some process was using it at the time, either the software center or perhaps it was during an update or an upgrade. Try again, making sure it isn’t in use first. If it still says it is, wait a few minutes and then give it another shot. I’d assume that PureOS periodically checks for updates on its own, and it would lock the file while it’s doing its checks.

If for some reason it seems to never not be locked then we’ll have to take a closer look.


#14

Hey guess what Gavaudan, I managed to sort it out, I now have a very nice looking PureOS installed on the all in one PC. Very nice outcome, and pretty straightforward despite the issue with being locked out from editing the sources list. Many thanks for all your help and patience its very much appreciated :slight_smile:


#15

Awesome! For posterity, what all did you have to do? Future users would appreciate your details.


#16

I basically went to command line using

sudo nano /etc/apt/sources.list

modified the entry by adding the following entries;

deb https://deb.debian.org/debian/ buster main non-free contrib
deb-src https://deb.debian.org/debian/ buster main non-free contrib

saved and exited sources.lists

ran the command

sudo apt update

sudo apt upgrade

After that I installed via the command line :

sudo apt install firmware-linux firmware-linux-nonfree libdrm-amdgpu1 xserver-xorg-video-amdgpu

then

sudo reboot

and voila it booted perfectly into PureOS with a crystal clear and clean display resolution.

Hope this is of help to future PureOS users, I totally get the fact that the distro wants to associate itself directly to non free software as it defeats the whole purpose of what Linux is about essentially but sometimes in life we all have to compromise a little :slight_smile:


#17

Good good, glad it worked out for you!


#18

and it’s better that we all now know how easy it was …