State of MMS on Librem 5


TL;DR: I am waiting to hear back from Purism on how to proceed with Chatty integration, and I don’t know the status of mmsd-tng in PureOS.

To be clear, I am not a Purism/Pine64/related employee, so I do not set priorities for them.

What I can tell you is mmsd-tng is in the pipeline for the Debian repo, it is in Mobian Unstable, and it is in PostmarketOS. I do not know its status for PureOS.

I can also tell you that I have a branch for chatty that supports (backend) MMS support, but still needs UI integration. But since I am not a developer for Chatty, I am waiting to hear back on how to proceed on (since I do not want to make changes then have to revert/change them again). You can see my MR here:

And my branch here:

Additionally, that branch is dependent on this MR to be merged into Chatty:


Niiiice thanks !

The “Mms support” issue was closed yesterday after a “Enable MMS support by default” change was merged:


Release 0.5.0 is currently being tested(which includes mms support). @kop316 and @mohammed.sadiq have put a lot of work into it, and should be thanked for their effort.

I’m testing it and have been reporting issues I see. Feel free to join in :). (NOTE: Do not send yourself an image yet, as there’s a bug with that).

WARNING: There may be bugs that make it unusable to you… Test at your own risk.


This is great news! I can barely wait for this to hit Mobian.

One bright spot in this government-induced “supply chain crisis”… by the time I finally get my Librem 5, the software will ROCK! :metal:


Now, chatty version 0.5.0.beta3 which is the released version in PureOS now, I have MMS working (after entering settings in ~/.mms/modemmanager/mms) but with the annoyance that when someone sends me an MMS that results in chatty creating a “group chat” with myself and the other person. The group chat comes up as a separate conversation in chatty, separate from my SMS conversation with the other person, which becomes confusing.

I think this happens because chatty is unaware of my own number, because none of the SIM cards I have tried (Tele2/Comviq and Telia in Sweden) seem to report the own number. Apparently some SIM cards behave like that. The phone/modem can ask the SIM card about its own number, but some (many) SIM cards just don’t implement that feature, I think.

Does anyone know any workaround for this?

1 Like

It might be some default configuration, group chats are MMS chats.

Hello Librem 5 friends. Some of you may recognize me from: “Got VoLte to work by enabling it… by following instructions written by smarter people.” I hope you’re ready for the sequel: Got MMS to work.

Again, for reference, I don’t consider myself a Linux expert by any means, just a user… who happens to like to tinker.

Setting - Phone set to 4G only. Using PureTalk (on AT&T backbone) with their SIM card. Standard texting (SMS) worked fine from the get go, and I fjust recently got VoLte working on the 4Gs. The next battle was MMS, since I couldn’t get group texts or **** pics.

In the Chatty preferences, Protocol settings, SMS and MMS settings I filled out the following:
APN: RESELLER [according to them, this must be in all caps]

As soon as I exited back out of the settings, all the group messages and **** pics that I missed over the last several days showed up at once.

It was a small victory, but I wanted to share that it CAN work, and provide what got it working for me in order to provide hints toward what may help you.


Is that a different APN compared to the APN you have for the regular mobile data connection?

Is mobile data working for you now, after you got MMS to work? One way to check this is to turn off WiFi and see if the web browser still works.


As I understand it, sometimes you can have a main APN and also a separate one for MMS, if the all-in-one APN isn’t getting MMS. Here’s what Ting (a T-mobile reseller) says on that:

Relevant quote (pertaining to Android): “Keep Ting Data selected as your APN. Your phone will use the MMS APN settings automatically as it needs.”

Yes, that should be possible, but I think currently it will not work on the Librem 5 due to this issue:


“RESELLER” is, in fact, the same APN that I had set for the data under the mobile - access point names settings. Data worked when I set it. I have not changed it. I just had to type “RESELLER” in the APN [as well as mmsc and proxy] in the chatty preferences/settings too. However, I did just check data now… and data no longer works. I may have just not noticed data not working since I got MMS going? I doubt it had anything with the update that just pushed. So, Skalman, your question was a good one, and now I’m perplexed. I understand why it would have trouble with a different APN between the two, but not with the same APN set for both.

I’ll walk around the house to verify that I’m not in a temporary black hole or something. I hesitate to play with it more at the moment, because I seem to use MMS more than mobile data.

I think it has trouble with the same APN set for both because the service provider insists on separating MMS from data i.e. the service provider insists on two different APNs depending on what you are trying to do (MMS v. mobile data).

And now, without any warning or changes, data started working again. And MMS has not stopped working. Glad I didn’t try to “fix” it! It probably would’ve started working on its own when I did something stupid, giving me the false sense that I did something right.

I see three potential reasons: I WAS in a temporary black hole of service at my house; my MVNO was having intermittent issues; or the phone was having intermittent issues. I’ll suspect the temporary black hole until something tells me different.

To sum up, I’m back to saying, everything CAN work at once.


I’ve been watching this thread with great interest. I saw that I got the required updates to enable MMS on my Mobian Pinephone, but it didn’t work until I tried the ninja APN naming trick. Boom! It worked… for about a week. Since then, MMS or MMS and data more or less randomly stop working, sometimes for weeks at a time. Sometimes there are “expired” MMS notices, other times bunches of group texts or pictures come through at once. :roll_eyes:

Seems like a similar experience, but different hardware? This is good, and getting better all the time. I hope to be as impressed with Purism hardware when I get my Librem 5.


Who is your service provider?

Mint Mobile (T-Mobile MVNO).

I have configured MMS on my L5, works great

When one picture is received, a preview is visible in the chat
But if multiple pictures are received, I got the link to the files

I think it’s probably related to SMIL, or some kind of groups MMS not fully supported yet
But, do you have the same behavior ?
Or, is there an option to add somewhere ?

1 Like

Similar on Pinephone-Mobian-Phosh. Multiple pix are always presented as links; single pix are a coin toss.

1 Like

ok thanks for the confirmation

You have single pix with no text that are presented as links ?

I feel like, for the single pix, it’s always nicely done, unless the single pix is grouped with something else (a text or an other pix)