State of MMS on Librem 5

Given that SMS and MMS messaging exists and can be used, it makes sense to do so cost efficiently. This is by no means a justification to send everything as SMS or MMS!


The only thing I am unsure of is whether I need to disconnect from WiFi in order to receive MMS messages, or whether it is enough to be connected to mobile data.

You can be connected to WiFi (or another network).

Can you file a bug report here:

and include logs from mmsd-tng. You can pull them with a command similar to: journalctl --user -u mmsd-tng --since “today”

Make sure the logs include a time that you attempt to send an MMS!


I have a question about “chatty” in mms of L5.
As far as I read this page, there are two APNs.
One for mobile and one for MMS.
APN for mobile is APN
APN for MMS is APN
Why is it still not working?
Should I hack and rewrite my files directly? ?

name Y!mobile APN
username ym
password ym
MCC 440
MNC 20
authentication type CHAP
MMSC http://mms-s
MMS proxy
MMS port 8080
APN type default,mms,supl,hipri

My experience is that the apn on both chatty and the modem settings need to be identical or it just doesn’t work.

If you need to use different apns I don’t think that works at this time.


MMS is working good on my side, if MMS does not working for you may be a bad config.
Mobile Access Point
Create a new Mobile APN and enable it.

  • Name: Y!mobile
  • APN:

Chatty: SMS and MMS setting.

Good luck.

Thank you all. I will try it today.

I tried, but “chatty” doesn’t show my friend’s cell phone carrier email address. The display of “chatty” is only the phone number. Do you have any special settings to make it MMS?

Put any phone number manually to test the MMS config. For MMS working it need Data from GSM or WLAN, just one source not both.
Regarding that Chatty does not show Contacts, may be a bug somewhere if i remember correctly, i will tracking this bug.

“chatty”, if you use MMS, do you configure XMPP for new accounts?

No, i not configured any xmpp account. MMS it different to XMPP, but XMPP can driver IMAGEN too.

how can you purge chatty history?

when deleting the history.db it doesnt appear to reset chatty. when user on other end sends a message (sms) it contains the history again including images i tried to send but failed to send.

1 Like

Chatty: SMS and MMS setting.
MMSC: http://mms-s

I can receive only the title with the above settings, but the date is .1970.01.01.
I wonder if I should edit the mms file directly or if it is a bug.
Please someone give me some advice. I would appreciate your favor.

1 Like

@hirohiro, this looks like to be in correlation:

Is there a way to have two connected APN’s in mobile settings at the same time?

My operator uses different ones for mobile data and mms. From the mobile settings, I can only choose one or the other. I have entered the mms settings in Chatty, but it doesn’t seem to handle mms unless I tick the APN for mms, which instead breaks cellular data.

dec 22 12:10:00 pureos mmsdtng[1326]: ../src/service.c:send_message_get_attachments() Content ID: IMG20221212120721-00001-00001.jpg, MIME Type: image/jpeg, File Path: /home/purism/.local/share/chatty/mms/2022-12-22T11:56:22+01001e41988e1c13b1416e1a1801cd01888ff1a0/IMG20221212120721-00001.jpg
dec 22 12:10:00 pureos chatty[1848]: Bearer Handler emitted an error, the APN set in mmsd's settings does not match any connected APNs
dec 22 12:11:37 pureos dbus-daemon[588]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.106' (uid=1000 pid=1848 comm="chatty --daemon ")
dec 22 12:11:53 pureos chatty[1848]: Bearer Handler emitted an error, the APN set in mmsd's settings does not match any connected APNs

No, I don’t believe so. I’m not an expert, just have done a lot of reading on the MMS stack for my own issue.
This is the issue tracking the problem from what I can tell:

I think it’s an oversight. Those two should not have to match.

Unless I’m mistaken, I think official MMS support was added today. Can anyone confirm?

P.S. To test it myself, I would have to switch to a different SIM and look up the carrier’s MMS APN settings. May do that later.

My situation:

Network: T-Mobile
Network Mode: 3G, 4G (Preferred)
(APN/MMSC settings match in both the Mobile Settings and in the Chatty preferences)
Using Chatty 0.7.0.rc5
Using Byzantium: Linux pureos 6.1.0-1-librem5

As of today:

  1. I can receive images and text from others in a group MMS but if I reply with text only, my reply is NOT received.
  2. Images that I send individually or to a group are NOT received.
  3. SMS messages I send to myself are NOT received.
  4. SMS messages I send to a single individual ARE received.

Do I need a new carrier?
Do these SMS/MMS messaging functions all work on AweSIM?

I had the same issue. Check out this post:

Assuming you are having the same issue…
Your mmsdtng version is older then 1.13 and has a known issue with T-Mobile.
Try ‘mmsdtng --version’ at the command line. What does it report?

It returns: 1.13.0