Steam (Linux client) on PureOS?

Hi, I was able to run Steam Linux client when I was running Debian Stretch, no problem. Between work I was able to enjoy short breaks playing Linux games, it’s great.

A few days ago I reinstalled my Librem 15 with PureOS 3 alpha.
Now I can’t install Steam Linux client anymore.

Referring to the guide at,
after running apt-get update, I got the following message :

N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'Index of /pureos/ green InRelease' doesn't support architecture 'i386'

At first I thought it shouldn’t be a problem, that I’d just get the i386 packages straight from Debian - so I added the following line to my source.list file :

deb [arch=i386] Index of /debian stretch main

Turn out I still couldn’t install Steam Linux client.

When trying to install the required 32 bit packages below :

apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libc6:i386

I got all sorts of error messages, indicating version conflicts, which very well may break the OS itself. example:

root@HSZ:/tmp# apt-get install libc6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apg : Depends: libc6 (>= 2.14) but it is not going to be installed
 cpio : Depends: libc6 (>= 2.17) but it is not going to be installed
 dc : Depends: libc6 (>= 2.14) but it is not going to be installed

And so on, pretty much all of the currently installed packages are listed.

So…I wonder if anyone else manages to get Steam Linux client installed on PureOS ?
If yes, how ?

Thanks in advance.

cheers, HS


Hi Harry,

first of all PureOS is only 64-bit (while steam and all libraries it needs need to be 32-bit (unless you compile it yourself into 64bit etc)). So there are no 32-bit libraries in PureOS.
Second, steam client is nonfree software so it will never be inside PureOS archive (unless they make it Free/libre which I doubt).

If you want to go with steam, Debian is the way to go in this case.


1 Like

Hi Zlatan, thank you for the reply.

I truly understand why Steam Linux client will never be in PureOS, and it’s very understandable - no problem at all.
I have no complaint whatsoever about it.

However, my post was really about 32 bit arch in PureOS.

And you answered that PureOS is 64-bit only, which makes sense, considering its specific target environment (Purism products)

That’s very understandable.

So thank you very much for taking time to clarify these to me.

I guess my only option now is to wait for Steam to release their 64-bit version clients.

cheers, HS

1 Like
I guess my only option now is to wait for Steam to release their 64-bit version clients.

No it’s not, you can install 32-bit system (debian, for example) alongside your existing installation, or just install the required 32-bit libraries.


If you really want steam, use flatpak. Since flatpak is already installed, you just need to add flathub repo and install steam from there

flatpak remote-add --if-not-exists flathub
sudo flatpak install flathub com.valvesoftware.Steam

Tested on PureOS (and apparently Fedora)…
Skype can be installed using flatpak as well…


Ha! Thanks. I had heard of flatpak only recently at debconf and found it a very interesting thing
I tried those commands and it worked, it installed Steam on my system (I use Fedora though not PureOS, but I don’t see why it would be any different on PureOS).

1 Like

My apologies for reviving this post, but I’m approaching installing Steam on PureOS. I’ve tried using apt, aptitude, and flatpak to no avail. Upon adding the flathub repo, my config looks like this (gpg-verify*=false to silence GPG verification related errors; toggled back to true when not working on this issue:)

[remote "flathub"]

And I get:

$ sudo flatpak install flathub com.valvesoftware.Steam
error: Remote listing for flathub not available; server has no summary file
Check the URL passed to remote-add was valid


1 Like

I have Steam installed via Flatpak with default settings on my Librem 13v2. Seems to be working great so far. I’m not sure I recall the steps exactly, but after a clean install of PureOS, I think just following the instructions on Flathub was enough to get the repo added and recognized in the “Software” app.

If you search “Gnome Software” within the Software app and select it, the app will bring up the info page for itself. Scroll down and look for Add-ons and see if Flatpak Support is checked. If everything is working you should be getting search results from the Flathub repo in the app and be able to install Flatpaks via the website (though that was really slow for me).

Looking at your config compared to the Flathub instructions, you might just have a typo in the URL (missing “dl.” before

Your config URL:

URL from Flathub instructions:


Thank you all for your help. I tried both with and without the dl, no go. I went to Flathub (and thank you for the link) and followed their instructions to set up the repo, which kind of worked. Then I tried to install steam and got an error saying the repo was already installed. So I uninstalled the repo, and then clicked on the link from Flathub to install Steam, and it is installing as I write. Thanks again, and I hope this helps the next person going to install Steam.

1 Like

Will this also work with the Librem 5? Or do we have even more problems there as it is nor 64 nor 32 but arm?

Indeed, that is exactly the problem. I don’t see how it could work on the Librem 5 since there is no arm-compatible Steam client that I know of, nor any plans by Valve to make one. Even if there was one, none of the games downloaded via Steam would be arm-compatible. It might be possible to develop something for streaming on an arm-based device like the Librem 5 by leveraging the Steam Link SDK, but I’m not aware of any serious project underway to accomplish that. This reddit thread might be of interest to you if that’s what you’re looking for.

Not to awaken old conversations but does anyone know if Steam would run on PureOS in these modern times. With the advent of Proton/Steam deck running Linux… etc…

I don’t have a Librem 14 to test it out myself (yet).

Thanks :smiley:

Works on mine.

1 Like

That is good to know thanks!

I’m trying to install Steam launcher and it’s failing with a message about requiring flatpak version 1.11.1 or later.

Currently installed flatpak version after running all software updates is 1.10.8

1 Like