Strange mic - bad sound/parasite

Dear all,

I have a microphone problem on my librem 13 v2 (uk).
When I want to use it my voice is inaudible and we hear parasites.
So I did a recording to check. Result of parasites, nothing audible

I wanted to see more ready by dismantling my computer and see what state my microphone was in (thanks to the information on this site:
And there … I see that

My computer is no longer under warranty. I bought it in November 2019 (1 year warranty).
How to repair?

Thanks for your tips.

Hey florent,

From the picture it looks like there’s some extra stuff on the plug. Is that I type of glue to hold something in place? Is it solid? Looks also like thermal paste but don’t know what it would do there. Looking at the exact wiki link you sent, it looks like the hardware kill switches might have something similar there, but again, really hard to judge from the picture.

The more obvious thing: It looks like only one cable is connected and that the red wire is not connected at all. Is that correct? If so that might be the first thing to do: reconnect the red wire. Question is how much slack to you have in the wire to simply reconnect it ? You might have to extend it. It might also be necessary to get a new plug, somebody can surely help with the type…

If the cable is indeed severed: How did that happen? I guess the mic worked at some point…

I, too, have no microphone signal (only static) on my Librem13v2 (see recent thread on the same topic here).
Here’s a photo of the same connector, in my laptop:
The connector has sockets for two wires:

  1. ground
  2. signal and power

As explained on a Purism blogpost, for an earlier model of the Librem.
This arrangement on our laptops ought to work, assuming:

  • the wire leading into the blob of silicone actually connects to something (I would assume ground), and
  • the manufacturing plant worker didn’t get the ground and signal sockets or wires confused!

I haven’t heard back from customer service yet. I’ll update this post when I do.

So you bought it second-hand? Otherwise I assure you that it is not yet November 2020. ??

It looks like a kind of dough. If you pass your finger over it, it’s dry and soft.

It seems to me that two cables are connected: a black and an extremely fine green.

The green cable is stuck in the strange paste.

For the red wire, I believe that it is not connected (I will check again by dismantling my laptop).
I don’t think I have enough length to connect my red wire.

“If the cable is actually cut: how did it happen? I guess the microphone worked at some point …”
Good question! but in view of the short length of the wires and the quality of the connections, I think it was not designed to live very long …
Finally, I confirm that the microphone worked in November 2019, the date on which I received my laptop. I did not use it until confinement.

Thank you @DHS for this information.

Sorry @Kieran, I meant November 2018. I had taken a 1 year warranty. European, I absolutely did not believe in the possibility of after-sales service.

You will still recognize that the level of manufacturing is not up to par?
I’m going to have to play the “Mc Gyver” to try to fix it all … if someone has tips to fix it … you’re welcome …

I have a Librem 13 v3 which I’m happy with overall. My internal microphone suddenly stopped working today after working fine for 2 years. It stopped working after I had the kill switch in the off position. Could that switch the the issue? My video is working fine. People can see me, but not hear me. I’m not muted and the internal mic doesn’t appear to be off in the sound settings.I bought a USB mic thanks to the advice on this board. Haven’t tried it out yet.
Is there any kind of fix for the internal mic available yet?

Would uninstalling and reinstalling the sound drivers help with my internal mic issue and how do I do that? Thanks!