Successful Reflash to Byzantium

I too find this annoying. Sometimes I just want to charge the L5 but I have to wait for the phone to boot and then power down right away. Is there a setting for this that I’m missing? If not, there should be a setting that selects or deselects this behavior.


Never tried. It should work, but you may have to manually adjust some stuff in some places. I’d say: make a full backup and give it a try :wink:

1 Like

:rofl: Maybe not…

  • Proximity sensor works much better during a call than I observed with Amber. Screen blanks out immediately when pressing to ear, and stays blank while in place.

Likely it won’t work unless that ‘stuff’ in those ‘places’ is documented. (It has been discussed extensively and commented on by Kyle - but that would have been for amber. q.v.)

I’m curious, @amarok, as to why you want to change the username. Some reasons that I can come up with, applying to myself, are:

  • logic - it isn’t really logical for the default username to be purism - it’s not as if Purism will be logging in to the phone - most distros solicit the default username on the first run and create the account at that time
  • vanity - want my own name there
  • security - it slightly eases the task of an attacker to know an existing (valid) username (however that actually argues against the second reason, just not to the same extent)

Solely for reasons of security. We L5 owners should not all have the same publicly-known user name.

Especially while using a simple 6-digit code.


I guess that means you’re literally one in a million.


I have changed the password on a Librem 5 device using passwd, sudo passwd purism and it worked, but i have not checked in detail if something broke. Have not tried from GNOME control center.

1 Like

There, but again backup stuff first:

1 Like

I believe the question was about changing username, not password?

1 Like

you are right, sorry for the noise :sweat_smile:

It’s still good to highlight alphanumerical password support in phosh, as that’s pretty fresh! :smiley:


You can also expand the list of apps phosh considers adaptive:


Speaking of passcode issues, I just eliminated the long delay that results from having entered an incorrect password:

sudo nano /etc/pam.d/common-auth

auth [success=1 default=ignore] nullok

auth [success=1 default=ignore] nullok nodelay

I realize this can increase the risk from a brute force attack, but now that we can make stronger passcodes, for me it’s an acceptable trade.


I did this yesterday. So far so good. I’m glad I eliminated the wrong-password delay, because I keep typing the old password out of habit.

The user settings in the UI haven’t been updated to account for alphanumeric yet, but no biggie.


This script worked perfectly, thank you for pointing out this Merge Request.
I wonder why it hasn’t been merged yet?

Just curious. Do others still get this FPS running this glxgears command on a librem5? I just tried it for fun and was getting more like 60-64.

Also did a reflash on my librem5 yesterday from a debian bookworm laptop
had to install uuu and some python3 packages
everything went smooth very easy to do following instructions from Purism website

@cyber_fu It means that VSync is enabled, and that glxgears is displaying frames in sync with the screen refresh rate. Run it like this to disable it: vblank_mode=0 glxgears, I get about 1000 FPS that way.

Sure enough, that gets over 1000. I guess now I’m curious why the initial excitement was for 140-150 FPS?

Oh well, still pretty good.