Sudo apt update fails since coreboot upgraded

I just finished updating coreboot and enabling my tpm module using the script and instructions from Kyle’s post. When I finished, my computer restarted fine. Two hours later, it suddenly shut down twice. Then upon reboot, I get the following error when I run sudo apt update.

Hit:1 green InRelease

** (appstreamcli:6482): WARNING **: No origin found for file repo.pureos.net_pureos_dists_green_main_dep11_Components-amd64.yml.gz
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.

Help appreciated.

This seems to have solved it:

sudo -i
apt-get clean
cd /var/lib/apt
mv lists lists.old
mkdir -p lists/partial
apt-get clean
apt-get update

1 Like

The above stops your sudden shutdowns, or just your apt-get issues or both?


1 Like

It stopped my apt issues, my shutdowns still do occur from time to time.

Try to listen if your fan is working. Mine was faulty so it might be the temperature that is getting too high and it shuts down to prevent damage?

I would write support, and get their take on it.

Thanks - it does work, but I will monitor.