[support] Can't detect headset microphone, how to debug?

I’m running up-to-date PureOS on a Librem 15v3. When I plug my headset into the audio jack, the headphones are detected (audio output switches to headphones, volume level is adjusted) but the microphone isn’t. I’m pretty sure this wasn’t the case with a previous headset (that I no longer have). How can I debug this issue?

So far I have:

  • tested with killswitch on and off (does it matter?)

  • plugged the headset into my phone and confirmed headset microphone (not phone mic) works there

  • checked “Sound” settings - “Output” switches from “Speakers - Built-in audio” to “Headphones - Built-in audio”, but “Input” remains at “Internal microphone - Built-in audio”

  • generated unplugged / plugged in logs (based on a related tip at https://askubuntu.com/questions/133809/mute-sound-on-headphone-unplug ):

    ~> cat /proc/asound/card0/codec#0 > unplugged.txt
    ~> cat /proc/asound/card0/codec#0 > pluggedin.txt
    ~> diff pluggedin.txt unplugged.txt
    <   Amp-Out vals:  [0x31 0x31]
    >   Amp-Out vals:  [0x00 0x00]
    <   Amp-Out vals:  [0x00 0x00]
    >   Amp-Out vals:  [0x24 0x24]
    <   Amp-Out vals:  [0x80 0x80]
    >   Amp-Out vals:  [0x00 0x00]
    <   Pin-ctls: 0x00:
    >   Pin-ctls: 0x40: OUT
    <   Power: setting=D3, actual=D3
    >   Power: setting=D0, actual=D0
    <   Amp-Out vals:  [0x00 0x00]
    >   Amp-Out vals:  [0x80 0x80]
    <   Power: setting=D0, actual=D0
    >   Power: setting=D3, actual=D3

Hi, same issue here with a purism librem 13v2.
I’m wondering if the mic input is wired or not… (I’m not sure it worked last time I’ve used it for video conferencing or if it was just the internal mic)

I couldn’t find in the specs if there is a mic input on the audio jack…

(FWIW I have since switched to a USB headset)

I am also having issues with the mic. I run into it when doing google hangouts. I get video but no mic. I have also then tried to pop in some apple headphones w/ mic and that also fails to work for me. Couldn’t get anything going via the sound settings.

In fact, the Librem 15v3 audio jack is output-only. It doesn’t support a microphone.

1 Like

I’m having the same issue, external mic not detected via 3.5mm jack.

@david.libremone can this really be the case that no input is supported in the jack? This should be a pretty standard prerequisite for any laptop… Purism even has the jack in the Librem5, so they know how important it is.

Yes, see the specs page please:


…the key words being “line output jack”

The Librem 13 version 1 (l13v1) supports an external microphone via that 3.5 mm audio jack. @mladen told me this and I just verified this with a TRRS (connector has tip, 2 rings, and sleeve) microphone. @mladen told me the CTIA standard is followed for the assignment of roles to the 4 contacts.

I don’t know when this functionality was dropped, but it appears to be gone by the l13v3. I don’t know whether the l15 ever had it.

Sorry for bumping, but tacere non possum.

Just ran into the same issue and was pretty surprised that there is no option for using any kind of “normal” microphone (be it separate 3.5mm jack microphone or a headset with TRRS jack) with L15v4. Thus, there are no simple options other than using the internal microphone.

The problem is that the internal microphone is completely useless as it gets muted by fans noise due to its weird location. It just records fans (which are pretty loud in L15v4). Of course, when fans are off, mic works as expected, but… Modern popular apps are not that lightweight (hello, Electron…).

Guys, I do believe that you are doing the right things, and I also believe that you hope that everyone reads technical specs carefully to notice the word “output”, but… The principle of least surprise is what should guide you, not formalities like “we wrote, and you should have read this”.

If I have a separate 3.5mm jack microphone + a 3.5mm jack headset with its own microphone + a laptop with its own internal microphone (!), and I’m still unable to make a call due to absence of suitable sound input… Well, that’s surprising and aggravating enough.

1 Like

Can you use a USB sound device for mic input?

I have one that has two separate connectors (standard green for speaker out and standard pink for mic in) but perhaps you can alternatively get one with a standard TRRS connector if that’s what you want.

Regardless, the USB device will present two interfaces and Linux will create one sound output device and one sound input device - and it should work fine to mix and match however you like e.g. use built-in sound output but USB device sound input.

Well apparently you are decidedly silent, muted by the lack of a working sound input. :slight_smile:

I’m using jabbra headset and that has no problem with any pc - can work via usb cable (emulating usb-audio) can work via BT, can work with own USB dongle (which is BT dongle essentially but still emulates USB-Audio on PC) and needs no firmware blobs to load.
And yes I’ve tried hell lot of other headsets but with all of them (but this) other people on the call were complaining on my audio quality.

[ 9153.932802] usb 1-2: new full-speed USB device number 6 using xhci_hcd
[ 9154.082149] usb 1-2: New USB device found, idVendor=0b0e, idProduct=245d, bcdDevice= 1.48
[ 9154.082156] usb 1-2: New USB device strings: Mfr=0, Product=2, SerialNumber=3
[ 9154.082161] usb 1-2: Product: Jabra Link 370
[ 9154.118879] input: Jabra Link 370 as /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.3/0003:0B0E:245D.0009/input/input38
[ 9154.173680] jabra 0003:0B0E:245D.0009: input,hiddev2,hidraw4: USB HID v1.11 Device [Jabra Link 370] on usb-0000:00:14.0-2/input3
[ 9154.238189] usbcore: registered new interface driver snd-usb-audio

    Jabra Link 370
    USB Stream Output

    Jabra Link 370
    USB Stream Output

It’s not a hidden commercial, I still have complains to their software and built-in integration with UC/Skype/Teams (using E75), but as a simple headset it does what it must.

1 Like