System error.What to do?

I got a brand new Librem 14. Enabled, entered the language settings, time zone, set the password for the disk. Everything was fine. After 40 minutes, the display turned off. I pressed the power button. Then I tried to turn it on again. I inserted the key and a message like this appeared on the display.(I want to note that I didn’t even connect it to the Internet) Guys, I’m asking for help.

For brand new Librem 14, probably best to contact

I expect something just needs signing.

1 Like

I’ve already written to them. I’m waiting for an answer.I thought maybe someone had encountered this.

@Veet If this was after the first reboot you probably did not update your checksums after a system update, as described in our documentation:

You can see what that process looks like:

To solve this please do:

  1. Restart (ctrl+alt+del)

  2. Wait for the system to ask you to insert your Librem Key, press ENTER (do not insert the Key yet)

  3. You will get into PureBoot menu, NOW insert BOTH your Librem Key and your Librem Vault (gold USB drive)

  4. Select Options → Update checksums and sign all files in /boot

  5. If the system asks you to “UNLOCK YOUR GPG CARD”, this means you need to type in your Librem Key USER PIN

  6. Default USER PIN is 123456 (if you haven’t changed it), type it in and press ENTER (there will be NO characters shown on the screen while typing your PIN, don’t let that confuse you)

Let me know if you managed to do this.


I am very grateful for such a detailed answer🤝. I’ll try to do it in the morning.

1 Like

It turned out to sign.The next step, the system requested a password for the lux disk. I created a password from letters, symbols and numbers. When you try to enter, the system does not allow you to print letters, it only allows you to print numbers. Am I probably doing something wrong?

Do you try 123456? or 12345?

123456 yes I tried to enter another code.In this case, the system prompts you to enter the correct code. Thus, I conclude that I enter the correct pin, but something goes wrong.

Sadly that i can not helping more for you, because i never used Pureboot, i have Coreboot in my L14.
I pretty sure that Purism will take care of this.

1 Like

You can always easily change the password used to unlock the LUKS slot later on, so you may be better off just going with numbers for now and getting to the next step.

Regardless, a picture of the screen may shed further light.

Have you selected an unusual locale? Without knowing that, I am not sure what “letters” means.

Likewise “symbols” could be an ambitious attempt to use Unicode characters (which is explicitly recommended against) or it could mean printable ASCII that is not alphanumeric (which could be OK).

@Veet A picture of the error would likely help.

The system does not accept a letter password. Accepts only numbers. At the time of the first setup, the system accepted a password consisting of letters and numbers.I have everything written down. I’ll probably have to reinstall the system. Could you describe the procedure? !(my password consists of letters and numbers, but the system only allows you to print numbers.)