System will not boot from USB

I have a Librem Mini that I bought last year. I created a Linux Mint USB (burned from Etcher) on my Windows machine. My windows machine recognizes the usb as a bootable usb. The Librem mini can read the usb just fine. But when I try to boot from the USB it does not appear in the boot menu. How do I make it appear in the boot menu?

I’m a linux newbie and PureOS is not easy to use, I cannot find any configuration or bios settings.

there aren’t any.

If your USB stick isn’t detected at boot time, try using a different port, or a different USB stick. It’s simply a hardware handshaking/init issue with the firmware. We can troubleshoot it with a debug firmware build, but the easiest solution is to just try another USB stick.

This comment is not intended to apply specifically to the Librem Mini but I have a computer that won’t recognise the USB flash drive if I put it in the USB 3.0 port but the same flash drive can boot fine in a USB 2.0 port (and of course every combination works fine once Linux is actually booted). In that case, there is not much point using a USB 3.0 flash drive as far as booting goes.

So I would suggest: use a USB 2.0 flash drive and put it in a USB 2.0 port.

Solely going from the picture on the Purism web site, the Librem Mini does clearly distinguish which are the USB 3.0 ports.

I tried both USB 2.0 ports with two different USB 2.0 flash drives and it still does not bring them up in the boot menu. Both flash drives are readable by the computer in Files. I believe Purism may do a USB boot bypass, but I cannot even find the BIOS in Systems or Settings to change it. Any help is greatly appreciated.

I’ve tried two USB drives in both ports and still nothing in the boot menu.

As was stated above, there are no BIOS settings.

Perhaps try to boot the standard PureOS live boot USB. That test gives you fault isolation.

as the person responsible for the firmware you’re running, I assure you there is no such thing.

Both? There are 7 USB ports on the Mini

So clearly I’m not speaking “Linux PureOS” correctly. This is my first Linux machine and it is so different from the Windows I’ve used for decades that I have a very difficult time figuring out how to do things. I understand there are 7 USB ports, I was referring to the 2 USB 2.0 ports using the USB 2.0 flash drives upon which I loaded the Mint OS. I also tried the USB 2.0 flash drives in the other 4 USB 3.0 ports. Regardless of what drive and/or port I use, I cannot get the boot menu to recognize the USB flash drive as a bootable OS.

those are two separate things, so which is your issue?

  • The USB drive is listed in the boot menu, but fails to boot
  • The USB drive is not listed in the boot menu

The former means that the ISO you’re trying to boot was not written to the USB properly.

The latter means that firmware isn’t able to init/handshake with the USB drive, or some other USB device on the bus is being problematic (like the keyboard)

The ESC key brings up the boot menu, but only PureOS is listed (in 6 variations). The flash drive is NOT listed.

I have a flash drive in the USB 2 port and the mouse and keyboard in the front facing usb 3 ports.

that’s not the firmware boot menu, that’s the OS/grub boot menu (loaded from the internal SSD).

You need to hit ESC earlier, on the Purism logo bootsplash, when you see the text ‘Press ESC for boot menu’.

1 Like

I was hitting ESC from the moment I turned on the power. I just waited until I got the ESC message and that seemed to work. Tricky timing.

Hopefully the rest will go smoothly. Thank you for your help.