Telegram-desktop: squeekboard overlays text input area

From one moment to the other the telegram-desktop app went useless because the OSK squeekboard overlays the text input area and you cant see what you type. Any ideas how to fix this?

Squeekboard never overlays anything, it pushes out windows. Are you sure it’s not the app that removed scrolling or something? Or, if you think it’s a window placement bug, then filing an issue in phoc would be the best way to go.

1 Like

I have here two screen shots, one before kicking up the OSK and one with OSK:

Are able to resize the window to the same size when you use a big screen?

I do not know how to resize the window of the tg app.

On Phosh, it works on a big screen only. It doesn’t have to be phosh though.

Go into the settings -> Advanced -> check “Use system window frame”

Thanks, but does not help.

The Flatpak version works better for me I think the one in the repositories doesn’t resize properly.

how about
select ‘Settings’ -> ‘Display’ -> set ‘Scale’ to 100% -> ‘Apply’

I did:

# flatpak install telegram
Looking for matches…
Found similar ref(s) for ‘telegram’ in remote ‘flathub’ (system).
Use this remote? [Y/n]: 
Similar refs found for ‘telegram’ in remote ‘flathub’ (system):

   1) runtime/org.telegram.desktop.webview/aarch64/stable
   2) app/org.telegram.desktop/aarch64/stable

Which do you want to use (0 to abort)? [0-2]: 2

The app starts ahd has the same problem with the OSK: it does not shift up enough when the OSK pops up.

The scale is set to 100.

Both apps (the telegram-desktop app and the now installed flatpack app) show an empty space on top between the upper border of the app and the top status bar of the phone, marked with a red line below the 4G indicator. This is exactly the space missing below of the text input field. Is there a config way to shift the app a bit in direction top, like one would do with the mouse dragging it a bit up on a normal desktop?

On pinephone, that space is closed by using the setting I mentioned earlier. I see you said you tried it and it didn’t work, though, which confuses me a bit. Perhaps the L5 has some phosh shenanigans going on that PP doesn’t. On the PP, I also see that the text field moves up and down with the keyboard appearance/disappearance, which makes it sound like this has become of case of apples and oranges. What version telegram are you using?

The version is Telegram Desktop Version 3.2.5

The settings of the display within the telegram app is confusing. If I click on the left hamburger, it says 100% if I go then into Settings there is a line of the Default interface scale with values 200% 220% 240% 260% 280% 300% , there 200% is blue, i.e. selected.

When I set the display scale of the L5 desktop which is normally 200%, to 150% all is fine, i.e. bringing up the OSK, shifts the tg chat high enough to have the text input visible completely. Maybe I should live with the 175% setttings, at least if I want to use tg.

Ah, it being a scaling issue makes a lot of sense (I haven’t messed with scaling at all). Since we’re talking about telegram, have you seen the right side of the chat portion being cut off? I don’t daily my PP, but when I do use it it’s a major annoyance

See this answer, it worked for me.

Yep, this time I’ve had to remove it, last time I’ve had to install it :slight_smile:

On Telegram flatpak
Do you receive notifications if you have closed the application?
And do you have the offset call window like this?

  1. No notifications when telegram is not running, also not when it is running.
  2. A tg call to the L5 is declined by the tg on L5.
  3. A tg call from the L5 seems to work, but the call window gets shifted as in your screen shot.

Under “amber” Telegram version .deb (1.5.11) worked very well.
I switched to Flatpak after the Telegram API update but I miss the old version.