Telegram Librem 5 and flatpak

Since 2-3 days I have an update that no longer performs on my librum 5, it is org.telegram.desktop that requires a higher flatpak version: 1.11.1

On the apt of librum 5 pureos I see that we are on 1.10.7

I unfortunately uninstall my version of telegram on flatpak and since I can no longer download it without this flatpak version error.

Do you know when flatpak will be updated on pureos ?
Or do you have a technique that works to install a particular version of a program under flatpak, when there is no longer the program. Indeed on the net I find a technique with “commit” but it only works if the program is already present.

Thank you :sweat_smile:

1 Like

Honestly, while the telegram flatpak worked pretty well, I have just moved to using the web client through ESR. That conforms to the screen size with no issues and works really well.

1 Like

Hello 2disbetter, thank you for your answer !

This is exactly what I did in troubleshooting solution, but this solution to the major inconvenient for a mobile solution to connect every launch on the web version the account with a code from another computeur with a telegram.

When I am on the move outside, I have no other computeur available. Or I have to launch the link before leaving and leave the web page open, which consumes the already limited battery of librem 5.

I hope the flatpak package will be updated fairly quickly. Unless there’s a way to send each other a permanent link to the browser, but I don’t know if that’s possible.

I had to reboot my L5 last night (due to run out of battery) and when I launch now FF with tg in one tab, I just connects to my tg account without any code from another device.

Same goes for the app. Just set the scaling in the preferences. I think mine is set to 170%, which results in a tiny font size, but it does fit the screen very well.

But I encountered the same flatpak issue. So, if someone could tell me how to update this (the repository?) I would be very grateful.

I have only the following flatpak (or better called fatpack) packages installed, and only the three marked with *** I remember having installed them on intention:

flatpak --columns=name,size list

Foliate                                   4.8 MB  ***
Goodvibes                                27.5 MB  ***
mpv                                      50.9 MB
Freedesktop Platform                    538.3 MB
Mesa                                    290.2 MB
ffmpeg-full                               8.5 MB
GNOME Application Platform version 42   724.1 MB
Telegram Desktop                        134.0 MB  ***
Telegram Desktop Webview Add-on          92.8 MB

Don’t know how the others came into my L5. I’d like to get rid off flatpak and using tg now in FF is a big step forward.

The platforms are needed once and the Flatpaks share these. Of course, installing just one Flatpak application makes this one really big but it levels down when installing further applications.

But, to get back to the problem at hand: how can we update/upgrade the flatpak version?

I am experiencing the same error as @MArty

I think this is due to the nature that PureOS Byzantium is based on Debian Bullseye. You can see here that the newest Flatpak version over there matches with the version we get in Byzantium:

One solution (caution!) could be adding the testing repositories in the /etc/apt/sources.list.

However, maybe some Purism dev can say wether that is really safe for the Librem 5 (as safe as testing can be) or wether there are better options to get newer software. I would be glad to do that personally because I do not use the Librem 5 as my daily driver.

1 Like

In any case, I confirm that the problem also affects the Debian distribution, so it is quite possible that this part will not be updated by Purism and that we may have to wait for Debian to update it to get the update.

Thank you for the advice on the web version, but as I do not keep the cache when closing my firefox (for reasons of anonymity in web consultation), I have to enter a code permanently.

Thanks for the solution on experimental deposits of the next version, I think it is indeed a viable solution to which I have not thought, I will make a try this weekend, I will keep you informed (maybe this will also fix the problems with librewolf)

I confirm that on debian it is possible to recover flatpak 1.14.4-1 using the bullseye-backports repo in the sources.list and make telegram operational again.

On the other hand, I stumble a little on the Pure OS repo, which I finally only use on the librum 5. Someone knows if there is the equivalent of a backports in this :

Currently my librum is cabled on all three byzantium, ( ) but I’m not sure what the others correspond to, will someone have a page that references what corresponds to what? Or an index of packages as found on debian? As we are on ARM, it seems to me on the librum 5, I wouldn’t want to make a bad move.

1 Like