Terrible graphic distortions in pureos


#1

After not using the computer in a while, on my Librem 15v3 I am getting bizarre pixelated graphics distortions. These can be induced by dragging a window to the right or left screen edge to lock

to one half of the screen. Dragging the window to top of the screen results in normalization. I’ve not seen something like this before. Tried changing application theme from default and turning theme animations off to no avail. Can’t think of any specific relevant modifications I’ve made to the system configuration. System is up to date. Any ideas? This is not a usable system situation…


#2

I’ve noticed this problem as well normally snapping to the top, then super-key + left/right solves this.


#3

yeah very easy to re-create just snap an item to the left side of the screen by mouse


#4

I have been recently seeing this display corruption as well, beginning around 2018-07-28. However, I only see this with web browsers, and it happens only when i use the GNOME window screenshot keyboard shortcut: Alt+Prt Scr. It’s repeatable with PureBrowser, GNOME Web, and Firefox. The issue is not present when logging in using “GNOME on Xorg” at the greeter, so I suppose this is yet another Wayland bug, since I normally log in using just “GNOME”. Since I first saw this issue, there have been several PureOS updates, but so far no change.


#5

Yesterday’s system update showed many GNOME packages upgraded to 3.30.0, but it did not fix this issue. In addition, this is not just happening with Web browsers. I have seen it now with a Kate (editor) dialog and another program (which I forgot to document).

To clarify, the window remaining onscreen is what gets the display corruption. The screenshots themselves turn out fine.

Double-clicking the corrupted window border to maximize the window clears the display corruption. Double-clicking again to return the window to its previous size causes no issue.


#6

This appears to be fixed with today’s (9/16) update. gnome-screenshot itself was updated to 3.30.0 and worked for me. You may wish to try it.

UPDATE: I should have thought of this: ‘Grab the whole screen’ and ‘Select area to grab’ seem to work for me. ‘Grab the current window’ does not.


#7

This issue was also reported at https://tracker.pureos.net/T531

The 3.30.0 update for GNOME Screenshot did not fix the corruption when doing a ‘Grab the current window’. As before, ‘Grab the whole screen’ and ‘Select area to grab’ do not have any problem. So, the bug is limited to grabbing a window. I used both the GUI and the keyboard shortcuts, and got no difference in results.

None of the display corruptions happen when logged in under GNOME on Xorg, so this is a Wayland issue. Canonical reverted from Wayland to Xorg for Ubuntu 18.04 LTS because of Wayland bugs and instability: https://www.omgubuntu.co.uk/2018/01/xorg-will-default-display-server-ubuntu-18-04-lts

As of today’s updates (2018-10-08), this issue persists and is still seen with a number of applications: PureBrowser, GNOME Web (Epiphany), Kate, and Okular. It seems to have been fixed for GNOME Files (Nautilus) and Thunar.

Thunar was updated today from 1.6.15 to 1.8.1 and while the screenshot issue disappeared, now it crashes immediately when clicking on any file. Crashing does not happen if logged in under GNOME on Xorg.