Terrible WiFi performance with Librem13, Librem15


#42

#metoo, but if the closed source driver really improves it, then the free driver can also be improved. In that case you can’t really blame the card. But it would be nice to see some activity there to improve the situation!


#43

There are various reports that turning off hw encryption can help slow speeds and dropping connections with atheros wireless cards. I haven’t been able to test particularly scientifically, but from some quick testing on an AP used by may people (and hence variable performance anyway), it looks like it might help in my case.

To test I unloaded the ath9k driver
sudo modprobe -r ath9k
then reloaded with the nohwcrypt option true
sudo modprobe ath9k nohwcrypt=1


#44

Any updates from Purism about this? I cannot use my laptop on campus because the wifi range is so poor. At home I get 1 bar when 5 feet from the router, something isn’t working right.


#45

I am also reporting poor wifi performance compared to other devices.

I own a Librem 13 v3


#47

This is a related problem that is linked to my topic as well. It went from super slow wifi, to now NO wifi. This is ludicrous. We pay top dollar for our machines. Aluminum case or not, we should still be able to actually access the internet. I am currently 12 feet from my router. I even tried sitting in front of the router last night and no dice…no access. I am currently using my wife’s reliable MacBook. I don’t have time to lose 2 hours daily attempting to obtain access to the world wide web. My wife’s machine gets 50mbs and I get 0mbs.

Somebody…help.


#48

Sort of a response to my own question and problem Does anyone know why Link Quality for my wireless signal get worse the more time I am online? It was a 97% after I went ahead and rebooted. it was fast for about 20 minutes. Now, the signal quality is starting to rapidly reduce.

Any thoughts will be great. As I stated, we pay a bunch of money for our machines. They should run at top notch performance more than most the time.


#49

This can actually be caused by many factors, so you need to eliminate them one by one.
Start with a live USB with recent wifi drivers, i.e. Ubuntu or Arch, then see if it improves.
Check your AP (router) wifi settings for anything not standard, especially if you run custom
firmware like openwrt (which you should anyway btw).
Which brings me to part 2, open the settings on your AP and check the logs there. Even the
crappiest models provide some sort of logging.


#50

Well, to a few of your points, I have had my Internet Provider out to my home between 5-8 times over the past few weeks. The speeds they check showed there was not an issue they saw. My wifes Mac never slows down. As stated, i restarted my machine and it was fast for a about an hour. I could see the link quality progressively go down. There is something wrong with a driver or the wireless card.

I have been blaming my issues on my Internet Provider and it does appear the fault lies solely with the laptop.

I run iwconfig intermittently throughout the day to analyze my signal and it gets progressively worse to the point of failure. The link quality is normally around 42 out of 70 There is a problem and it needs to be resolved.


#51

Interesting. Runtime or daytime related?
Are there other networks near you, possibly on the same channel?
Are you on 5Ghz or 2.4Ghz?


#52

Unfortunately, the speeds are non-time-specifc. The only remedy I have found is to restart my laptop. That works for a short while. I am not a hardware expert, but it has to be either the wireless card of driver. It is almost like he wireless card loses strength or it somehow leaks as it were.


#53

Here are my latest readings from iwconfig

wlp1s0 IEEE 802.11 ESSID:“XXXXXXXXXXXXXX”"
Mode:Managed Frequency:5.765 GHz Access Point: XX:XX:XX:XX:XX:XX
Bit Rate=45 Mb/s Tx-Power=17 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=46/70 Signal level=-64 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:933 Invalid misc:5358 Missed beacon:0


#54

I had a similar weird issue with a former ISP. I never figured it out. But with a new router and ISP my Wi-Fi works as well as non=free clients . It shouldn’t have made any difference but it did


#55

@steven.ellsworth40, does toggling the killswitch on/off/on have the same effect as restarting? You could try the unfree driver, but I’d rather first try 2.4Ghz, as hinted early in this thread.

@tregeagle rest assured, the ISP had nothing to do with it, not even the actual router. It can only be the hot-spot itself, which of course is often part of the router. But you could have kept the ISP/router, disabled the WiFi in it, and attached a stand-alone hot-spot (assuming of course, that this hot-spot does not produce the same problem). Not suggesting to do that, just pointing out the technical context.


#56

I have noticed severe wifi issues that seem to occur only after a resume from suspend or hibernate. Reboot always fixes it, and the issues do not recur until a sleep/resume. For me, toggling the killswitch makes no difference.


#57

My speed is down around 30% right now I attempted toggling the kill switch. It did not remedy the issue.

I had been told the aluminum case of our machines does provide for a more difficult connective issue. That being said, It will not the reason I am 80%-100% lower than my wifes Macbook.


#58

I just attempted in restarting my Llbrem15 in an attempt to regain the 30%. Even that did not work. Please keep in mind, my wifes Macbook will always be at the upper levels of our access point.

I will continue to monitor, but there is something definitely wrong with either the wifi card or driver.


#59

Try running a live OS from an external USB if it’s an option. That way you will know if it’s something in
your current OS or hardware, or other reasons, which can be many actually.
Macbooks have a different chipset and drivers, (802.11ac on all models since ~5 years) so their signal
is better compared to 802.11n. Nothing can be done about it since the 802.11ac firmware is not free.


#60

(emphasis mine)

Well, actually, there’s a chance that the neutralization of the Intel ME has undesired side-effects. I remember reading something like that in the past, to the effect that some missing initialization produced subtle errors.
In that case, a live-distro would not show a difference.
But it’s worth a try, of course. The live-distro would likely use the proprietary driver that is not included in PureOS.


#61

I just checked my wifi speed. it is down 75% since last night at 9PM. The folks at Purism have to do something. This is lunacy to have a wifi connection that is this erratic.

It goes from optimal, to slow, to nothing, and eventually, back to optimal.

Purism Support: Please find a remedy to this issue.


#62

@Caliga In that case (Intel ME) many people would complain about similar issues. And by that I mean pretty
much anyone who uses wifi, since it is a reproducible bug from the past.
He said something about dropping signal, so it’s not something ME can sporadically control. That will be a conspiracy theory on a new level :slight_smile:
The ath9k driver is free and open source in all distros. Unless he uses a 3d party wifi module which is unlikely.

I don’t think it’s a support issue, since it doesn’t look like a hardware issue - unless you can confirm it with
more testing and logs. There is no magic way for them to look it up from you remotely…
Maybe you can post your AP settings, while removing the private information parts?