Testing Fractal (dev version) on the L5

Hi all. Could someone with a Librem 5 test out the development version of Fractal, a Matrix client? The installation instructions are at https://gitlab.gnome.org/GNOME/fractal/-/tree/fractal-next#installation-instructions. I’m just interested in whether things generally work, if it’s horribly broken, if the interface is reasonably adaptive, etc. Thanks.

Hey, I’ve been testing fractal-next on my PinePhone and it fits the screen and generally works. The version I’ve built is not totally recent (as I installed it via AUR PKGBUILD which requires GTK4 and libadwaita built fresh from git which may break some other apps), and aside from it not being good at loading old messages (scrolling back does not work for me) it’s quite solid.
So if you’ve got some time and free space on the eMMC, or another ARM64 device, e.g. a Raspberry Pi 4, go build it!

Awesome, thanks! And @linmob you’ll be happy to know that scrolling back has since been added to the application.

I just started building fractal-next with flatpak, I’ll report back once it’s done (seems like it will take a while to compile, hopefully my device does not go out of RAM while linking).

While I compiled, I came across this issue: https://github.com/flatpak/flatpak-builder/issues/92
Simply had to run “sudo apt install elfutils” to fix it.

I also had to change a few lines in the Cargo.lock file, since apparently a few matrix-rust-sdk related packages pointed to non-existent SHA commits for some unknown reason.

-source = "git+https://github.com/jsparber/matrix-rust-sdk.git?branch=messages-api#3ebe24550697e357f5165cb021d4e3ee82455730"
+source = "git+https://github.com/jsparber/matrix-rust-sdk.git?branch=messages-api#0074fa9d076db4544e11c2811a2420103d7f30cc"

Then I let it compile during the night, but apparently the device crashed. The RAM usage was at 2.96GB out of 3GB, so probably ran out of RAM and died.

So to get it working I guess you have to cross-compile it on a device with more RAM available unfortunately :frowning:

1 Like

I was able to cross-compile Jumpdrive (and that seemed to be a hefty build). So the cross-building tools do seem to work OK.

It would be good to know upfront though approximately how much RAM is needed because otherwise the result with, say, 16 GB of RAM can be the same as the result with 3 GB of RAM (i.e. abject failure) but it takes 16/3 times as long to get to the point of failure. :wink:

Does the project give any guidance on system requirements for building?

You could set up some swap to solve the out of RAM issue.

Yeah, that would probably be easiest. I don’t think it needs significantly more ram to complete either, just a few hundred mb extra. I also think the rust compiler which fractal uses eats more ram than most other compilers and languages.

There are also Flatpak builds available from the repository, if installing from there is easier. As of me writing this, the most recent Flatpak build job is https://gitlab.gnome.org/GNOME/fractal/-/jobs/1552120, from which you can download the Flatpak file by clicking the “Download” button on the right side. I got there by navigating to https://gitlab.gnome.org/GNOME/fractal/-/tree/fractal-next, clicking the green checkmark near the commit hash (in the box above the list of files), and clicking on the round “flatpak” button further down on the page.

2 Likes

@enterprisey Oh, that sounds a lot easier.
Anyhow, got it compiling finally but it crashes every time i open a conversation. The rest seems to work fine though such as logging in, exploring rooms, joining rooms etc. Will keep on using the old version though.

yeah that’s a bug with the current version… people are looking into it

I concur with “fits”, but can’t judge “generally works” because it errors on logon with a useless message. I have Librem Social and matrix.org accounts (both work in Firefox). Fractal fails when I try credentials and servers for both accounts. I’m probably missing something obvious…

The current version errors on logon with a useless message (something about weak refs), unfortunately, unless you’re talking about “unable to save session”, which I put in recently and is totally normal (to fix, install some sort of keychain software, like gnome keyring).