The "| + \" key on the keyboard doesn't work, and installing non-gui distributions is impossible


#1

Hi,
I’d been waiting to get a librem laptop for so long, and I got my wish granted today when it came home in the mail. Unfortunately, I was disappointed almost as soon as I booted off the gentoo livedvd, because the |\ key north of the enter key doesn’t work. Every | is reinterpreted as > key and every \ is reinterpreted as <.

Edit: It appears that in this thread they detail a partial solution to this problem by manually remapping the keycodes. This is a hardware issue with the keyboards Purism is selling. I shouldn’t have to go out of my way to find an unstickied thread on the purism forums and then enter a command every time I boot just so I can pipe output. If purism knows about this then they should either stop sending out laptops until they fix their hardware or send an email to everyone who buys them telling them they need to implement this workaround if they want to type correctly.


Librem 13v2, German keyboard & PureOS: "angle brackets & pipe" key dysfunctional
#2

It’s fixed, wait for the upgrade: https://tracker.pureos.net/T328


#3

He’s using gentoo, not PureOS. Fixing it via systemd doesn’t work anyways because gentoo uses openrc by default and for its installer, which is what he is trying to work with. This is a hardware problem and needs to be fixed hardware/firmware wise, not through a systemd patch.


#4

It’s fixed, wait for the upgrade

  1. I don’t use PureOS

  2. I don’t use SystemD

I feel like I’m being a dick about this but that’s not a fix, it’s a software coverup of a hardware issue, and its a coverup only for the segment of your customers that use your linux distribution instead of Qubes or Gentoo or Arch or whatever.


#5

Using Qubes here so I also do not use Pure OS. I asked mladen for help on an email and received the same link to the thread that is anything but straight forward so my pipe key still does not work.


#6

In the case of Qubes I think you can follow these directions in dom0 since Qubes is based off of Fedora. Since Fedora also uses systemd you could try this as well.


#7

I’ve the same issue with Librem 13 and PureOS. I got the keycode 43 for Pipe and Pound Sign on a german keyboard. Udev rules or setting the keycode doesn’t work. There is no issue in Qubes 4 RC5.


#8

I take it this is one of the new V2’s? That’s frustrating. What layout?


#9

I am using a german keyboard layout and it’s only an issue with the Pipe key in PureOS.
Yes, it should be Librem13 V3.


#10

Are there any plans to fix this in Coreboot or on the Embedded Controller? I am also using Qubes and having to remap my keys with a script is quite unfortunate when this was a hardware/firmware issue. I am using the Librem 13v3 with a US layout.


#11

Thank you, that fixed it for me!


#12

You are not, I understand, but cannot help you now. We are looking into this.