The "| + \" key on the keyboard doesn't work, and installing non-gui distributions is impossible

He’s using gentoo, not PureOS. Fixing it via systemd doesn’t work anyways because gentoo uses openrc by default and for its installer, which is what he is trying to work with. This is a hardware problem and needs to be fixed hardware/firmware wise, not through a systemd patch.


It’s fixed, wait for the upgrade

  1. I don’t use PureOS

  2. I don’t use SystemD

I feel like I’m being a dick about this but that’s not a fix, it’s a software coverup of a hardware issue, and its a coverup only for the segment of your customers that use your linux distribution instead of Qubes or Gentoo or Arch or whatever.

Using Qubes here so I also do not use Pure OS. I asked mladen for help on an email and received the same link to the thread that is anything but straight forward so my pipe key still does not work.

In the case of Qubes I think you can follow these directions in dom0 since Qubes is based off of Fedora. Since Fedora also uses systemd you could try this as well.

1 Like

I’ve the same issue with Librem 13 and PureOS. I got the keycode 43 for Pipe and Pound Sign on a german keyboard. Udev rules or setting the keycode doesn’t work. There is no issue in Qubes 4 RC5.

I take it this is one of the new V2’s? That’s frustrating. What layout?

I am using a german keyboard layout and it’s only an issue with the Pipe key in PureOS.
Yes, it should be Librem13 V3.

Are there any plans to fix this in Coreboot or on the Embedded Controller? I am also using Qubes and having to remap my keys with a script is quite unfortunate when this was a hardware/firmware issue. I am using the Librem 13v3 with a US layout.

Thank you, that fixed it for me!

You are not, I understand, but cannot help you now. We are looking into this.

Look, this is completely ridiculous to see from a laptop geared for Linux. The pipe character is essential to any terminal workflow. It definitely doesn’t take a year of “looking into this”.

I just bought a Librem 13 v4 in the mail, got a v3 since apparently paying for v4 doesn’t mean anything, two of the screws on the back came stripped which made installing the nVME hard as hell without breaking anything, and it still has old issues like this.

What is Purism doing over there? I already pre-purchased a phone, but honestly it’s not looking like I made the right decisions at this point.

1 Like

I’m installing FreeBSD and I had this issue a little bit ago, try the uk layout, should fix your pipes :+1:

What layout do you have?
How did you conclude it’s a v3?
Did you contact support?

Sadly, the problem is with the Embedded Controller which is actually closed source (even to Purism). It’s actually quite surprising that the controller being used to handle ALL laptop keyboard input, charging and battery communication, and much more, is something we have no view into, modifications aside.

I did some research when I first got my Librem 13 v3 and found out the EC is the same one used in the OLPC laptop (something I actually did a lot of work on). The source was released, along with a lot of information on it. I’ve done BIOS/EC keyboard mapping swaps before with the ThinkPad T430S, so I figured maybe I might have a shot helping out. I emailed Youness Alaoui before he left Purism, and he gave me a very stern warning against messing with the Embedded Controller as much has changed with it since it was used in the OLPC, and they do not know any details.

I do agree that this is ridiculous though to keep using such hardware in, how many models/revisions now??

Rant aside, I love my Librem 13 more than any other laptop I’ve owned :slight_smile:

I’m looking into the Librem 13. If I buy one today, will this key work?

It works correctly in PureOS, but not by default in Qubes. Not sure about other distros but it is definitely annoying :slight_smile:

Qubes can be fixed by adding a one-liner to a dom0 config, it took me quite a bit of digging to find it, but if people are still having issues I can find it again and post it here. It is an incredibly annoying issue though, considering how many commands need | to work.

Yes, please do!

This looks like what I remember finding that worked:

Can you try that solution and see if it still is functional? If you still have problems, I can try reinstalling qubes and retracing my steps.

Thank you, I will check it out. Don’t worry about reinstalling! :slight_smile: