Thunderbird fails to open attachements

I have installed PureOS on my laptop and configured Thunderbird as my email client. When I try to open an email attachment – a jpg image for instance – I get prompted what program would I like to use. When I choose the /usr/bin/eog, nothing happens.

A friend of mine who uses purism has the same problem on his laptop with a default installation.

Thank you for any suggestions how to solve this issue.

Make sure sure everything is updated on your system: sudo apt update && sudo apt upgrade && sudo apt dist-upgrade then do a reboot and if that does’t do much, try the solution I found here:

  1. View -> Message Body as -> Original HTML
  2. View -> Display Attachments Inline (check it)
  3. Preferences -> Attachments -> Incoming - see if the file type you are trying to open is listed. Make entries and assign an action or select “Always Ask”

Thanks @anon10067017, unfortunately that doesn’t work.

I actually get asked what program I would like to use (that’s the prompt I was talking about in my question), however, even when I choose the correct program, and try to continue, nothing happens, i.e. the file still doesn’t open.

I can still save the file and open it manually, but that’s not the most convenient way.

I wonder if anyone else has had the same problem.

So the problem was caused by App Armor. The solution is described in here.

In summary:

  1. install apparmor utilities sudo apt install apparmor-utils
  2. change apparmor profile in sudo aa-logprof
  3. mark aplications to authorise as child (option C) and agree to sanitise the environment (option Y)
  4. finaly finish the program (option F).

The program you authorised should now open properly. However, you will probably need to do it for each individual type of file that you are going to receive. I wonder if there is any way to allow all of them directly.

1 Like

I did ‘goldenbear672’ solution.

step 2 : sudo aa-logprof

below what I get but no ‘child’ (option C)

Profile: thunderbird
Path: /usr/local/lib/
Old Mode: r
New Mode: mr
Severity: unknown

[1 - #include <abstractions/ubuntu-browsers.d/multimedia>]
2 - /usr/** mr,
3 - /usr/local/lib/libso mr,
4 - /usr/local/lib/* mr,
5 - /usr/local/lib/ mr,
(A)llow / [(D)eny] / (I)gnore / (G)lob / Glob with (E)xtension / (N)ew / Audi(t) / Abo®t / (F)inish