Time to flash is now - but how?

@irvinewade @amarok
I did everything in Post 16, step x step, checking and double-checking as I went.

I answered the questions above. A lot of lines (4k+) went by and ended at a command prompt. Nothing to say it was a success, or error - nadda. The most major change is back to micro-fonts. Everything else, chats, high score in 2048, images are all still there.

Someone else, can’t remember who, mentioned the other method of booting the device with a USB and wiping and installing PureOS - again.

Is it possible to rebuild the device into a L5 using the USB format then install method?

1 Like

I don’t know anything about that myself.

1 Like

You successfully showed me how to use that method to install PureOS on a desktop.
Well, I doubt anyone else has any ideas on fixing this thing or I would have read it by now.

I guess it’s sell it for parts now. Offer?

1 Like

Suggestion: Go through the entire process again, and before closing the terminal on your computer, copy and paste the entire terminal text to here. If there’s anything you don’t want us to see, such as your username on the computer, XXXX it out.

When posting the output here, place the triple symbol (backwards apostrophe without the quotation marks) " ``` " on the line before and the line after your paste here in the terminal. Example:

(the triple symbol goes here)
all of your text
the triple symbols
(the triple symbol goes here)

This will put your long, long terminal output in a small scrollable window to conserve space and make it easier to scroll.

Maybe somebody can identify the errors and offer a fix.


Unfortunately a typical desktop / laptop does work differently. Realistically the only way of wiping a Librem 5 and starting again is to reflash - using the procedure discussed here.

I concur with amarok’s suggestion: try to reflash once more, capturing the entire session and let us see whether we can get to the bottom of it.

But before you do that … on the desktop / laptop, please post output from
which uuu
uuu --version


I started this on Thursday 27.
I had already done that and offered to post the whole thing. I was shown how to post it inside a scroll-abled window - akin to a iframe.

I already did that, I think twice for both desktop and L5.

All that said and done, I already went ahead and re-re-re-flashed the L5. I haven’t gone through the log looking for errors amd/or warnings

However, I will post the few lines at end of flashing cycle so you can see how it did.

59%|███████████████████████████████▏                     | 630784/1073880 [00:00<00:00, 2207793.09it/s]
            Enter the flashing mode by holding volume-up button while turning the phone on.

            If it's not detected, follow these steps:
            - Ensure that the phone is powered off
            - Turn all Hardware-Kill-Switches off
            - Unplug the USB cable if connected
            - Remove battery
            - Hold volume-up button
            - Insert the USB-C cable (red light blinks, no green light)
            - Reinsert the battery (red and green lights constantly on, the script will continue)
            - Release volume-up button

100%|████████████████████████████████████████████████████| 1073880/1073880 [00:13<00:00, 2207793.09it/s]uuu (Universal Update Utility) for nxp imx chips -- lib1.4.77

Success 1    Failure 0                                                                                 
3:1      5/ 5 [Done                                  ] FB: Done                                         

Flashing complete.
2024-03-28 16:13:23,661 INFO Cleaning up.

As stated, there are 4403 lines of text in the log. Amarok suggested editing any identifiable data before posting. When I have time to read the log novel, I’ll post it.

Friday 28th a.m.:

  1. Psycho tap is back.

  2. Some screens are so small no one could read them. i.e. First required password (using setup default 123456), is the one that goes nuts with one micro-line that tells one to enter password. unless one taps the micro-square bottom right nothing to enter.

  3. Tapping Settings to set up mobile and wi-fi only loads 1 thing, airplane mode, and wi-fi settings. Only by peck & hope did I find that the rest of everything that is under Settings is off-side.

  4. Now just trying to get aligned with Mobile provider KoDoo.

It appears that by the lack of any previous data the last flash has worked.
Everything that needs to be added, adjusted like mobile settings - not the mobile on the menu, the other mobile, and the Chat fix and so on, page sizes…
I’m learning. Pray for me. :rofl:


What did you do differently this time?

1 Like
  1. First fail, I think, was L5 cable was too loose in contact with L5. Swapped out cables. (because I noticed the screen flicker).
  2. Second fail I think was no uuu - installed that.
  3. Third fail I think, was that one of the devices had Amber, the other Byzantium - fixed that more help from here. And retried the flash.
  4. Fourth fail, I think was due to how the L5 was loaded from a night of charging. Fixed that. (More on that in another reply - link coming)
  5. Fifth fail, I think may have been the point where the script is “Searching…” for the L5. Is it possible there is a unmentioned time-out point where it stops ‘searching’?

On top of all the stuff that had to be done differently, this Last try, I watched the screen intently for the “Searching for…” line and quickly connected.
:partying_face: :tada: :piñata: :+1: :clap: :star_struck:


So, if I can summarize where things went wrong (I think):

Because your computer was running PureOS amber, which does not include the uuu application in its repositories, it would have been necessary to use the previous flashing method, which involves building uuu oneself first. Therefore, uuu was not found when you attempted to flash.

Once you upgraded the computer to byzantium, which has uuu prepackaged in the repo, the package was found and used in the flashing process normally.

Then, as you said, you watched for the “searching for…” output and connected the L5 at the appropriate time.

Glad you got 'er done! Maybe some of the previous issues you experienced are now fixed.

And my bad for not anticipating that your machine might have been running amber instead of byzantium.


I intend to add a suggested list of things to check-off before starting a flash and handing the check-offs over, for what it’s worth, to Here to be used or not in the How to Flash the L5 FAQ or whatever. It might be handy for those newbies like me.

You’ve summed it up nicely except I can’t be certain it was the Host that had Amber, or the L5 because I seem to remember that I was surprised that the phone came /w Byzantium. I’ll have to go through a lot of long logs.

There must be something that has a list of searchable commands such as those for uuu.
Adding to the pithy Pearls of Wisdom, I keep my friends close and my enemies closer, and PureOS cheats beside me. :thinking:

Thanks for all your help and valued patience,


Maybe you could go back and edit post 16 to mention that scenario in the comment before step 1: PureOS ⇒ PureOS byzantium or later

You could also be more specific regarding Ubuntu and just specify Ubuntu 22.04 LTS (jammy) or later. (I understand that you may have wanted to include the possibility of using Mint but in that case you should also look up what the corresponding version of Mint would be.)

1 Like

I noticed a while back that editing of my post #16 was disabled, so someone will have to re-enable it for me. Maybe you or @JCS ?

1 Like

Discourse only enables editing posts up to a month old.

1 Like

But it can be re-enabled by someone with the proper privileges.

1 Like

Please try again. I increased the TL2+ post edit time limit from 1->3 months. TL0/TL1 remains the same for security purposes. This should allow you approx 2 weeks to edit post #16. I am amenable to increase the post edit further, but am making less drastic modifications to start.


Done now.



What if one spends hours and days preparing, and finds they have the antique “amber”, and not “evergreen”? Then what do we do to get from Amber, to Evergreen and Byzantium?

p.s. I was too early in clicking “Solution” I should have tried sending pics w/ texts. first.

1 Like

“Evergreen” is the current production version of the Librem 5 (hardware).

“Amber” and “Byzantium” (and soon “Crimson”) are iterations of the operating system.

The flashing process is precisely to replace the operating system, either to go from an earlier to later version, or to reflash the existing version.

EDIT: Notice the theme: a - b - c.
Amber - Byzantium - Crimson (names of somewhat exotic colors in the art world)

Birch - Chestnut - Dogwood - Evergreen - and someday, Fir (names of trees)
Evergreen was the first “finished” commercial production batch; birch through dogwood were commercial releases, but still somewhat “beta.” (further edited for clarity)

1 Like

Thanks amarok, , but my question is/was:

. I did spend half of today looking for that answer - now I ask.
i.e., I need to know what is on the Host and target - the L5.

We, you I and Irvine and Frank and so on updated the host to Byzantium (as far as I know ( as well as the phone). But, I’m fold the Host is Amber (still) - I need to know these things. I’m asking for a friend :lying_face:

1 Like

To go from amber to byzantium on the L5, you do exactly what you’ve done already: flash the device. (“Evergreen” is not a version of PureOS; it’s a hardware model of the L5.)

The command lsb_release -c should return “byzantium” if your flash was a success. (You’ve already indicated the flash showed “success,” but please verify.)

And if you run sudo apt update, you should see output indicating that the pureos-byzantium repos are being checked for updates.

Where do you see “amber,” or who said this?
By “host,” do you mean the computer you used to flash the phone? What does lsb_release -c show on the computer?

1 Like