"Timeout was reached" selecting network in mobile settings

I’ve bought and activated a mint mobile sim card.

As I understand it I need to enable mobile data, and use 4G only since they shut down the 2g and 3g stuff. I’ve tried fast.t-mobile.com, and wholesale as my APN. I’ve tried setting “Network” to “Automatic”, and manually setting it to T-Mobile and Mint. I’ve tried combinations of all of this, because I’ve seen all of these different things suggested in whole or in part. In every scenario when I try to connect to a network I get a little “Timeout was reached” notification, and if I look at the modem details, the network status will be “unregistered”.

Of course, that could also be it. That the network status is unregistered. Should I get in contact with someone from mint? What would I even say? Like I said I’ve already activated the sim card and can log into a mint account and view my remaining data etc.

If anyone could help me out, or point out something I’m getting wrong, I’d appreciate it.

Unless I’m mistaken, you have two distinct issues here:

  1. Connecting to the cellular network
  2. Enabling mobile data

APN settings only affect issue 2. If your SIM card shows that it is unregistered, then you have to solve issue 1 first. See if any combination of settings under the “Network” and “Network Mode” menus gets your SIM card to show up as registered.

1 Like