Toolbar less user friendly after latest FF update

I reinstalled an older version with

apt install firefox-esr=102.10.0esr-1~deb11u1

and lost all my bookmarks. But at least it works again.


I did the same and restored the .Mozilla folder from a recent backup and everything is back to normal. I have also put firefox upgrades on hold until the issues are resolved.

1 Like

Everything appears to work in landscape mode so that appears to be the workaround if you need to use these buttons.

1 Like

Ok, but awkward as I usually have portrait mode locked on my L5.


Landscape mode just disables all modifications, but fix nothing. Flickering is there, addons cannot be put into overhang menu and even touch input gets disabled from time to time (I had same issue as guru on some sessions and now I think it’s a new problem of FF and not that Phosh issue).

I got enough for now and also reinstalled the old version. Just don’t forget to restore the .Mozilla backup (like tomoqv said) or you will run into issues or even crashs.

We definitely need better improvements than just CSS-fixes.

1 Like

There is no need to put Firefox updates on hold. Just install upstream mobile-config-firefox, which already works with 115: postmarketOS / mobile-config-firefox · GitLab

You need to change firefox to firefox-esr in lines 8 & 9 of Makefile · master · postmarketOS / mobile-config-firefox · GitLab before running sudo make install.


If anyone is interested, I just submitted the September 2023 Update for Firefox-ESR 115 on my Mobile-Friendly Firefox Customizations post.

@linmob, I think you suggested in a previous post that these forums are not the right place to post such code. I agree, but there are no better options for me. I am not interested in creating accounts on github, gitlab, or any other similar sites

As per the MPL-2.0, you and others are free to share and modify the code wherever you want. I’m not a developer/programmer. I just like to custom configure my browser-of-choice and thought I’d share my work with the world in the most convenient-for-me way I could. I have also linked to my forum post on kbin so that more people could see it (if it federates properly).


I think you have no fix for addons, do you? Otherwise 115esr is still not usable for some of us. I was looking further into about:config setting and found a method in 109 to enable overhang menu extensions again, but those options don’t exist in 115 anymore. :face_with_symbols_over_mouth:


The tabs can be fixed by using Ctrl + T using the Terminal layout to open a new tab. After that, you can freely swipe them like before.

I may or may not bother to do something about the rest of the UI, but if I do, I will provide another response with solutions to this thread.

How I have to protect my FF 102.10.0esr-1~deb11u1 against future updates, because the update is offered again?

1 Like

I proceeded this way:

As root, create a file: /etc/apt/preferences.d/firefox-esr

And put this contents in the file:

Package: firefox-esr
Pin: version 102.*
Pin-Priority: 1000

apt-mark hold firefox-esr


That’s even easier than my solution! I’m sure there are differences between pinning and holding but for the current case it won’t matter much. Learned something new today!

For future reference: Ubuntu Manpage: apt-mark - show, set and unset various settings for a package

showhold and unhold will be helpful


Correct. There is nothing that I can do about Mozilla being Mozilla. Hopefully they will add features to the new Unified Extensions Menu, such as the ability for extensions to expand into it like the Widget Overflow Menu previously allowed.

On a side note, I’ve noticed another bug in the new Firefox-ESR:

After using Firefox for a little while (I don’t know if this has to do with time spent or number of tabs opened/closed), single-taps no longer work in certain parts of the browser. For instance, if I use the Tab Manager to switch or close tabs, I will eventually need to double-tap in order for the button to be clicked. When this happens, Firefox registers a click on the button I’m tapping as well as whatever is behind the button. I’m guessing this is a touchscreen related Firefox bug.

This is really annoying, and I hope they fix it soon.


I wanted to install firefox-esr=102.10.0esr-1~deb11u1 as well in my other L5 but it is not fetchable any more, it says:

$ sudo apt install firefox-esr=102.10.0esr-1~deb11u1
[sudo] password for purism: 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Version '102.10.0esr-1~deb11u1' for 'firefox-esr' was not found

Any location from where I could get it?

1 Like

You can use an old Byzantium image.

I found it in the other L5 as file /apt/archives/firefox-esr_102.8.0esr-1~deb11u1_arm64.deb and scp’ed it to the new L5. How can I install from this file?

1 Like

Assuming it is in the same directory as the other Librem 5, open a Terminal and use this command:

sudo apt install '/apt/archives/firefox-esr_102.8.0esr-1~deb11u1_arm64.deb'

Thanks. I learned that I have to provide a fully qualified filename and it worked.

1 Like

See: How to remove the Firefox Unified Extensions button and restore the Overflow Menu - gHacks Tech News

You might also need the CSS module that a commenter posted there.

I’ve applied this to all my computers except the L5, but there’s no reason it shouldn’t work on the L5, too.

1 Like