Tor Launcher is not working


#1

Hi,

Through the ‘software application’ I use the Tor Launcher to get the installation done but I get a signature verification failed.
Like on Tor website (https://www.torproject.org/docs/debian.html.en) even if I do the following command :
gpg --keyserver keys.gnupg.net --recv A3C4F0F979CAA22CDBA8F512EE8CBC9E886DDD89
gpg --export A3C4F0F979CAA22CDBA8F512EE8CBC9E886DDD89 | sudo apt-key add -

It still does not work.
Any idea ?
Thanks


#2

Run this command in your terminal:

gpg --homedir "$HOME/.local/share/torbrowser/gnupg_homedir/" --refresh-keys --keyserver pgp.mit.edu

and then restart the Tor launcher.


#3

it works perfectly ! you’re a rock star :star_struck:
Thanks


#4

I’m in the process of setting up my new Librem 13.
I am getting the following error at the 28% point of the of Tor Browser install - “Unable to install Tor Browser Launcher as download failed”". I have tried running the terminal command you suggested on the 17-Jul thread, but upon restarting, I still get the same error message. Any suggestions appreciated


#5

Did you forget to update software repos? Run in terminal the following order:

sudo apt update && sudo apt full-upgrade

enter your password when asked and hit enter and wait for the command to finish, then try installing the TorBrowser launcher again.


#6

Yes, the software update fixed the problem and I was able to successfully download TorBrowser — thanks!


#7

If not doing a sudo apt update first, it seems to create a lot of issues, and not everyone can have the patience and time to come to purism forums and search for a solution. I’d see this as an important issue and I’d suggest at least informing people about the need of running this command right after they install the OS. Sure fixing the issue at its roots would be better but I’d guess that the team is very busy atm and you might not have the time fixing it.

By “informing people” I mean adding a temporary slide to the OS installation process, warning them about the issue and listing the steps needed to take in order to fix it. Few lines of text, not more - but they can do a lot imo. Cheers!