TouchEgg in PureOS

I am new to PureOS and also pretty new to linux in general. In Ubuntu I was able to install TouchEgg from the repos. How do I go about installing an application that isn’t in the PureOS repos?


You could try these instructions

PureOS and Ubuntu are both based on Debian, so the package names might be the same.

1 Like

I actually tried following those instructions. I got an error when trying to clone from github. I must be missing some prerequisite to be able to clone from git. I don’t recall the exact error but can post later. Something related to “git clone command was unknown”. I have already done an update to apt-get so maybe git clone isn’t in the PureOs repo either?

git clone

Ah, yes, you would first need to install git.

sudo apt install git

Thanks! I have git now. On the second step I am getting an error now too. “sudo apt-get build-dep touchegg” The error is => You must put some ‘source’ URIs in your sources.list
The only repo in sources.list is “deb green main”

Does anyone know if I will run into issues if I add the Ubuntu repo to my sources.list file?

It appears pureos repo doesn’t contain as much as ubuntu repo but I am not sure if I should avoid trying this.

Hmm, I believe that is discouraged.
What features does Touchegg offer that you want to see? Just curious

Edit: Having looked at the instructions again slightly more carefully, have you tried skipping the build-dep part and doing this instead?

sudo apt-get install build-essential libqt4-dev utouch libgeis-dev libx11-6 libxtst-dev

You can set it up to do different gestures with the touchpad. I like 3 finger swipe to go back a page in a browser.

There are the two packages that I am having trouble getting installed. “utouch” and “libgeis-dev”

If anyone has suggestions on how to proceed please let me know. I am guessing I need to find the git code and manually build them, but not positive.

libgeis-dev is in Debian, so if you add Debian to your sources.list you ought to be able to pull that in. I can’t find “utouch” anywhere, not even in Ubuntu. What is trying to pull that in? What error messages are you getting?