Touchpad Driver Librem 13v1 with new kernel

Hi there,
I run Debian (sid) on my Librem 13v1. I had some issues with the trackpad at the very beginning, which I solved installing this driver:

However, it looks like this driver is not supported anymore with newer kernel versions. With the normal xserver-xorg-input-synaptics driver, the trackpad is recognized as “Generic PS2 Mouse”. The software switch (Fn+F1) does not work, among other issues.

Does anyone have this issue and if so, how can be solved? Thanks in advance.


the touchpad is a PS2 attached mouse on the 13v1. The software toggle was broken in the most recent coreboot release, and will be fixed in the next one


Understood. I wasn’t sure anymore if the issue was due to the coreboot update or to the system update, since I did both on the same day. Now it’s clear. Thank you.

1 Like

Why is that? I mean, does this not limit the functionality of the trackpad?

On the contrary, it gives more security on Qubes OS, since USB devices are less secure:

very few touchpads are USB-attached. The vast majority are wired via I2C, and exposed to the OS via ACPI as HID I2C devices. Older devices like the 13v1 have the touchpad wired via the ps2 aux (mouse) port

1 Like