Trackpad cannot be used while the Keyboard is being used

The trackpad does not respond if a key on the keyboard is down.

Try it if you have a Librem laptop please. Push the letter t (or whatever key) and then try to move your mouse cursor with the trackpad. You’ll notice that while the key is down, the trackpad does not respond.

Is this a hardware limitation, software limitation, and is there a way to get both working simultaneously. This kills a number of tasks. I’m hoping there is a solution.

Does it make a difference if it is a modifier key (like Shift or Ctrl) that is down?

I think it’s a software config in “Gnome Tweaks” under Keyboard & Mouse there is an option for Touchpad.
“Disable While Typing”


Thank you @Manuel and my apologies, Purism for thinking it was a hardware problem!


I think it’s actually solving a problem i.e. that fat-fingered people unintentionally operate the trackpad while typing and so it is easier just to disable it while typing.

1 Like

My palm hits it all the time, I very much welcome the feature.