Trackpad not working PureOS 8 Librem 13v2

TL;DNR: Installed PureOs from USB onto new Librem 13v2, but the trackpad doesn’t work.


  1. How do I get the trackpad to work? Logging in works fine, but the trackpad doesn’t work.

  2. How do I update PureOS? When I tried sudo apt update && sudo apt upgrade it turned out that I’m not in the sudoers file. I tried rebooting and logging in as root with the root password, but I was told the attempt failed, no reason given.

TMIA, |r:b:

This will soon be deprecated, us Live install option and perform installation using Calamares installer.

But here’s a quick “fix” of that sudo problem:

(you need to be logged in to your desktop session, open terminal and follow the instructions above).
Then try updating your system, and restart to see if the touchpad works.

Hi mladen,

When I try the Live install option and run Calamares, all that happens is that (1) Calamares appears in the top menu where I cannot reach it without a trackpad, and (2) a spinning icon near it indicates it is doing something, and disappears after a minute.

Can you suggest a way to run Calamares successfully without the trackpad?

I’ll try the usermod suggestions in the meantime, and let you know.

Thanks, |r:b:

Hi mladen,

I tried to update as root with sudo apt update && sudo apt upgrade, but I get the following error:

E: The repository ‘ green/updates Relese’ does not have a Release file.
N: Updating from such a repository can’t be done security, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Do you have any suggestions?

Kind regards and thanks, |r:b:

Also, when I run the Live install option, the trackpad still does not work.

I ran Calamares by pressing the “Windows” key, typing ‘Calamares’, then using the arrow key to select it from autosuggest.

When instead I run Calamares from the command line ($ calamares), I get an Installer window that says my computer does not satisfy the minimum requires for installing PureOS 8:

  • There is not enough drive space. At least 5.5GB is required.
  • The system is not connected to the Internet.
  • The installer is not running with administrator rights.

FYI, the non-live Installer wizard did let me connect to local wifi successfully. I don’t see a Calamares command to do that, with or without the trackpad.

Thanks for any suggestions, |r:b:

  • Well, I was able to Live install, connect to the network, and do sudo apt update && sudo apt upgrade. Still no trackpad.
  • Rebooted. Still no trackpad.

Does anyone have any suggestions?

By the way, when the computer boots, the first message is an now unencouraging failure message:

  • Failed to load i915/sk1_dmc_ver_1.26

FWIW, lsb_release -a says I’ve now got PureOS 8 green.

BTW, in Settings the Trackpad is on. (I did check that! :slight_smile: ).


Fn-F1 enabled the trackpad. What made me think to try this was a post on how to turn off the trackpad: BYD touchpad - tap to click

So… so far, a sub-optimal setup experience with the Librem: I don’t understand why none of the steps I had to brute force are listed anywhere on pur.ism?

Thanks for your help. I’ll see how it goes with this laptop from here.

Kind regards, |r:b:

1 Like