Transferring files from iPhone 13 to PureOS (Librem 14)

Hello,
I am trying to transfer videos from the iPhone to the laptop. The phone shows as mounted, as normal and some pictures are shown, but the videos in question are not showing up on the file explorer on PureOS. I suppose that this is due to part of the file system on the iPhone not being recognized?

How could I resolve this issue and transfer video files in the size of 3-5GB to the laptop?

Does iOS have some sort of file browser, such that you could actually see which directory they’re in? (I don’t know.)

1 Like

Yes and that is the thing, in the default location or even if I create a new folder there, it is unseen. I have seen similar issues like this with android and it came down to a file permissions or trust concept, but that was a few years ago and on Ubuntu…

1 Like

Does the computer display the file system of the iPhone when connected (except for the missing files)?

Can you install a different iOS file browser to see if it behaves differently?

Are the videos perhaps actually stored in iCloud, but not on the device?

They are most definitely on the device. The file browser on the phone shows them, no issues. iCloud is disabled. I can see pictures and some videos. But videos of a certain size and above are not seen at all.

This issue could be happen too if Apple coded the videos/partition onto owner format, which GNU System is not recognizing the files or partition.

.MOVs are being recognized and are seen, its as if there is partial support. I tried several things, including installing shotwell and other apps to try to identify the files, but nothing changes.

1 Like

You might need to install something to read HFS or HFS+ (apple file systems, but I don’t know if the iPhone uses them. I would imagine so).

1 Like

You could try the KDE Connect testflight and send files to the computer that way I believe.

Link: https://github.com/KDE/kdeconnect-ios

Video example of this (around 2:45min): https://www.youtube.com/watch?v=d4ghirmM1Ys

1 Like

I think this is more of a situation involving the iPhone than it is involving GNU/Linux. As such, this might help even though it is targeted for transferring files from an iPhone to Windows10 ( https://appletoolbox.com/what-to-do-if-you-cant-transfer-photos-from-iphone-to-pc/#Importing_from_Newer_iPhone_Models_and_Windows_10 )

You mentioned 3-5GB. I don’t have an iPhone so I’m not sure, but I believe that it uses MTP (media transfer protocol). MTP is limited to file sizes of 4GB or less.

1 Like

That is exactly what I have set up. There is a 4K video I have that is about 10 GB and that is not shown, but is visible in both the files and the photo app.

In the link I posted did you look at “Some iPhone Photos Not Visible While Transferring to Windows?”. From what I understand, even if iCloud isn’t currently “on”, the phone doesn’t have the actual file (it has a cached “optimized” version somewhere else of the file and, so, MTP won’t see the file). Thus you need to:

In Settings > Your Apple ID > iCloud > Photos, switch from “Optimise iPhone Storage” to “Download and Keep Originals”

That said, I’m not sure MTP (Media Transfer Protocol) will handle/show files over 4GB in size.

Again, I don’t have an iPhone and I think this is an iPhone issue rather than a GNU/Linux issue. I use GNU/Linux with an Android phone and mostly deal with music (which doesn’t have filesize issues) —> I had to write my own “sync” (instead of using rsync) since there were issues due to filename mappings). I have noticed that MTP is rather slow (and has limitations).

I have noticed incredible latency that is for sure. I am waiting on an android phone in the mail and using the iphone temporarily. Do you also have any other issues with the android?

No. But I’m only moving music and photos. No movies.

Also, I just looked at my code and the filename issue was not directly an Android+MTP issue, it was because I was writing to an SDCard in the Android phone and the SDCard was vfat.

1 Like

I didn’t check repo.pureos (and actually have no clue) but still might help for some orientation if you ensure (in order to connect this particular device as an external drive) presence of the following packages:
apt list libimobiledevice6 libimobiledevice-utils
apt depends libimobiledevice6

1 Like

I’ve tried this and it does not work. What I did is copy the entire DCIM folder successfully and I did notice latency dropped, but other strangeness happened. First, the typical prompts for showing transfer progress do not update.

Second, even though the 10 gig file is inside the very same DCIM folder, it does not copy it.

From the looks of it, this seems to be just behavior of Apple. This is literally the last fucking straw with these guys. Who cares how good the cameras are if you can’t get the damn video off the thing…

1 Like

The final thing that seems to be working is an app that turned the iphone into an ftp server…what a shit show…

2 Likes

Perhaps this old school guide helps (please adjust if/as necessary): “It’s a slightly bitter victory, but still.

apt list ideviceinstaller python3-imobiledevice libimobiledevice-utils libimobiledevice6 libplist3 python3-plist ifuse

sudo apt install ideviceinstaller python3-imobiledevice libimobiledevice-utils libimobiledevice6 libplist3 python3-plist ifuse

Etc., as linked above.

1 Like

Making the iPhone an FTP client might work too if you have an FTP server running somewhere in your network (not hard to arrange with Linux).

I had the same problem some years ago (getting files out of the Apple prison) and used IMAP - but that isn’t going to work with GB movie files. Worked OK for the much smaller (but more numerous) files that I was trying to exfiltrate.

1 Like

I love snapdrop.net for this sort of thing. As long as both devices are on the same local network, you can transfer files easily.

2 Likes