Tried to switch to KDE and no app menu at all


#1

I just followed these directions:

https://tracker.pureos.net/w/pureos/tips/install_kde/

to install KDE plasma. I didn’t bother with the PIM Stack or anything below it.

On rebooting and logging in I get an utterly blank desktop. I can switch to other desktops, and I can get into setup and the file manager, but there’s NO evident way to open any other aps at all. (There’s nothing at all on the lower left, if that’s where it’s supposed to be.)

I couldn’t even get konsole to open from the file manager (it doesn’t appear to be regarded as a program at all).

So I think something went wrong, but how do I fix it when I can’t get to a command line?


#2

So just to confirm, you log in at the login screen, selecting KDE from the session menu. And from there, a blank screen…

If that is the case, once at the blank screen, you should be able to get to a terminal with ctrl+alt+f2. The command “kstart plasma-desktop” should get KDE going if it was installed entirely. If that doesn’t work, you can try reinstalling using the guide from that same terminal.


#3

Ugh. A restart showed me I was still running “gnome classic” (which apparently defaults to four desktops), so I had to change managers at the login screen.

Seems a lot better now.


#4

Thanks, but apparently I DIDN’T select KDE from the session menu and was dealing with a crippled instance of Gnome, and didn’t realize it.

Sorry to waste everyone’s time.


#5

No worries! We are a community here and it only works if we all help when we can :slight_smile:

Glad you got it going.


#6

The Iron Rule of Steve trying to figure stuff like this out–I figure it out on my own immediately after calling for help…


#7

Sounds like it might be the rule just before Murphy’s.


#8

Hey, to get a better compatibility with Plasma I would suggest you to disable GDM sudo systemctl disable gdm, rebooting into tty, and starting sddm to test if it works properly sudo systemctl start sddm and if everything works you can enable sddm to be greeted by it everytime you start your system with sudo systemctl enable sddm.


#9

Yuno:

The directions I followed did specify switching to sddm in the process of installing the updates. So hopefully, this is taken care of, or am I missing something?

(As a side note, once I figured out how to get pager to show (it won’t if there’s only one desktop), I found this much more “friendly” to me; unsurprising since I use some variant of KDE at work and have for years. I gave gnome a chance, truly (I bought this system several months ago), but I’m already much happier with this. Of course, it’s truly a matter of personal preference.)