Troubles with Firmware

When booting my PureOS I run into an error screen as follows:
ERROR radeon kernel mode settings for R600 or later requires firmware installed.
ERROR amdgpu requires firmware install.

I am using an AMDA6-7400K Radeon R5 test computer. It is using a 4GB Hyperx RAM stick.

The problem I am seeing is that since PureOS is Intel based and I am using an amd processor, there is typically going to be some missing packets. To counter this, I have about 12 hours of research into PureOS trying to find the correct firmware, information, functions, and more behind the devices so that I can find the solution. I came to the conclusion that the source.list was probably the best approach and tried editing it with vim and nano, but had no luck in getting any new firmware. It may be because of the new infrastructure that PureOS is using and I’m not getting it into the correct source.list.

At this point it is almost a lost cause for me. I’m on a time crunch for a school project just to explore PureOS and its functionalities. Personally, when it worked, I really liked it. I was only able to play with it for an hour before it crashed and those ERROR(s) came up.

Update 2/19/2019. I am in the sources.list using the correct pathway now. I have tried the steps below. The issues I am running into is that I have no other way to get into the system other than just using terminal. Is there any other recommendations on what “http://” website references that I could add to get this desktop to work? I cannot drag and drop packets to download and update my system so I need to have them listed in the sources.list

nothing to do with being “Intel-based” – your graphics card simply requires binary blobs (firmware) to function, and those components are not included in PureOS by design. As with Debian, you should be able to enable non-free components and have the proper blobs installed, but that somewhat defeats the purpose of PureOS

I did read that somewhere. I know that by default, non-free components were disabled, but at this point it really doesn’t matter to me. It ran once and I want to experience the operating system again before this project come due. How do you enable non-free components so I can get that firmware installed.

You just need to add a repository containing the packages you need to your sources.list file. Or to a file in your sources.list.d directory.

man sources.list

should give you all the information you need.

Just to get this straight, my repository is not located in etc/apt/source.list. I tried editing that file with vim and nano but had error issues when I was using sudo. Reasons being 1st it said it didn’t exist and 2nd I didn’t have permission to save it in that location which was weird using sudo.

I am not very fluent in Debian’s file structure and I am very lost at this point. I know I have to add url links to the source.list.d directory file, but have no idea how to find it, I have an idea on how to edit it, but no idea what to add (url or something other) anything to it.

Thanks for the information though. I feel like I am getting closer to figuring this linux machine out. I’m sorry I’m such a newbie to this though. Gotta start somewhere

Uh oh, watch for typos :slight_smile:
1st: missing leading slash, 2nd: it;s sources, not source, like this:

/etc/apt/sources.list

Those two typos explain in full the errors: the specified file did not exist there, moreover the specified directory etc/apt don’t exist in your home directory and you can’t create a file in a non-existing directory, root or no root.

3 Likes

If you don’t want to use Debian repository to install firmware, you can download it from Debian site (just click to any link in list)
https://packages.debian.org/buster/all/firmware-amd-graphics/download

and install it using apt-get.
sudo apt-get install ./firmware-amd-graphics_20190114-1_all.deb

Replace ./firmware-amd-graphics_20190114-1_all.deb to absolete path to downloaded package. You can also drag and drop file to terminal. This action automatically paste absolete path to file.

1 Like

Thank you for pointing out such a simple mistake. You are absolutely correct though, it is sources.list and I did find it because of that. WOW. I will continue my search from there and keep posting and trying to find firmware. Thank you.

1 Like

I am not running a virtual machine. I am doing an OEM boot using a flash drive with an ISO. There is no drag and drop. Originally I had the OS working, but after a re-boot for testing, it crashed and those warnings/ERRORs came up not allowing me to get back into the OS GUI. Instead I am stuck on an infinite loading screen and have to reboot into safe mode -> then press Ctrl+Alt+F2 to get into terminal, login, and then start the whole sources.list editing.

Is there anything else I can add that would clarify the details behind my issue?

Is this the manual for sources.list? If so how do you get linux to show you it? I don’t quite understand what information you were trying to give me. I’m sorry, I am not that literate in Linux yet, but I am trying very hard to be.

I think the OP was saying that if you were to run this command in the terminal;

$ man sources.list

You will receive information on the sources.list file. Traditionally UNIX came with a manual built it. To read the manual one would type ‘man’ at the command line. That tradition has continued in Linux though documentation is a bit more spread out nowadays.

2 Likes

I thought so, i will try it. Thank you