Ubuntu erratic mouse cursor, click dysfunctional, clipboard randomly pastes

Ubuntu erratic mouse curser, double/click dysfunctional, clipboard randomly pastes text, drag and drop dysfunctional and other spontaneous anomaly

On my Librem laptop 15 v4 running Ubuntu 22.04.3 I’m getting several erratic behaviors.
For which, so far, I’ve found no rhyme or reason:(
This has been happening for the last 10 days since installing Ubuntu.
I’ve tried updating software, tweaking Settings and all the usual fixes one would try in this situation.

1st: Erratic mouse curser, sometimes clicking the OK button in a dialogue box to close or a tab to close (in Files manager for example) doesn’t work. To work around I’ve been simultaneously using trackpad and wired mouse, alternating between the two, also have been trying double clicks on either. Or using ctrl key in conjunction with mouse curser to click. Or other wise dicking around until the tab closes or OK button in a dialogue box works. This doesn’t happen with some apps such as Firefox, Brave and Opera web browsers.

System Monitor is showing normal resources, nothing to indicate any problems.
Incidentally System Monitor is one of the problem apps, to change tabs I need to double click or swap from mouse to trackpad or visa versa. Some times a click followed by a double click will successfully change to a different tab.
Some times clicking on a tab will randomly popup a dialogue box with Take Screenshot/ Hide/ Maximise/ Move/ Resize/ etc.

2nd Dragging a window to a different place on the screen is some times random and problematic. Some app windows are immune to this anomaly such as browsers.

3rd Window contents randomly changing. So far this anomaly is only happening with Settings window, which happens even when it’s not the active window. See attached screenshots.

4th Various app windows sometimes don’t close when clicking the top right X. Work arounds have been all of the above mentioned. Some apps are immune to this anomaly such as browser windows.

5th When using Terminal it’s problematic when trying to C&P text strings.
(so please try refrain, if possible, from solutions that involve using Terminal)

6th Dragging and dropping files between windows is problematic. Renaming files is problematic and requires persistence and repetition. This is particularly my experience when moving and renaming files from Files manager, screenshots, and to email client as attachments. So much so that I’ve copied screenshots from my Librem 15 to another computer to make this post.

1 Like

When you say “updating”, do you mean

a) applying all updates that are available for 22.04, or
b) updating to the latest release of Ubuntu (23.10)?

Given that you have been using Ubuntu for only 10 days, I guess you don’t have a big investment in it and wouldn’t mind doing the latter if that is not what you have done. If you don’t wish to upgrade release then you can still do a Live Boot of 23.10. (The hope is that this is a kernel issue and that a big jump in kernel version will get you one that works for you.)

A bigger picture question is: what distro were you running before Ubuntu and were you experiencing the same or similar problems and, if not experiencing these problems, what kernel version was that?

Random observation: if you have, or can enable, an SSH server on the Librem 15 then you could SSH in from another computer and then hopefully you could complete any shell commands without any problems.

1 Like

Updating. a) applying all updates available for 22.04
I installed from fresh, Ubuntu 22.04.3 LTS.

I guess upgrading to Ubuntu 23.10 as you suggest is a good option if an easy simple solution can’t be found.

I’ve had my Librem 15 for a while and was running PureOS.
I’ve also run live USB distros Linux Mint 22.04.3, PureOS 9.x, PureOS 10.3, Ubuntu 21.x and also of course Ubuntu 22.04.3 LTS from which I installed. At your suggestion I’m now downloading Ubuntu 23.10 and will run the live USB on my Librem, but I don’t anticipate erratic cursor behavior as none of the live distros have done this. Never have I experienced this collection of erratic problems until installing Ubuntu 10 days ago.

Note that Ubuntu 22.04.3 live there were no problems but with Ubuntu 22.04.3 installed there is problems.
I’ve just rebooted to the USB live distro again to double check and there is no problems.

SSH, good idea!
I’ve never had to use SSH to remote but that will certainly be easier than battling with random cursor/ text pastes in Terminal directly. I will use this temporary work around if necessary.

1 Like

As @irvinewade suggested I’ve just created an Ubuntu 23.10 live USB and booted from it.
I’m surprised to say the erratic problem is there, less noticeable, but it is there:(

This time I opened a text editor, typed strings of text, then with the trackpad tried to highlight text for copy but it wouldn’t highlight, as a work around I used an external mouse, this highlighted the text, good.
Some times the trackpad will work as expected to highlight, other times is wont!

Next I tried using the trackpad to move the cursor to another place but a dialogue box popped up (cut/copy/paste/delete/undo etc) This doesn’t happen with the corded mouse. (Unless I tell the mouse to do so by using right click) Other times the trackpad moves the cursor in the expected way, no problems.

Another time I highlighted text with the mouse (since the trackpad on that occasion wouldn’t), good, then using the trackpad tried moving the cursor to another spot but the cursor immediately pasted the text to that new spot, when trying to move the cursor again it again pasted the same text appending it to the previous erroneous paste. When again trying to move the cursor the same happened again.

On the other hand using the mouse, moving the cursor was easy then using the mouse to paste to another selected spot, no problem.

I tried the above in LibreOffice Writer and got similar non uniform results.

1 Like

Then I guess the next thing might be to Live Boot the latest PureOS.


This sounds to me like the external mouse is intermittently disconnecting and sending spurious clicks:

  • The change shown in the Settings window is that the “Mouse” section disappeared - that’s normal if you unplug or plug in a mouse, if it’s jumping around it sounds like the mouse is spuriously disconnecting/reconnecting.
  • Many of the problems sound like spurious clicks being transmitted, like the unexpected paste (middle click), unexpected context menu (right click) and probably also the difficulty dragging (any spurious click).

The fact that you can sometimes drag with the external mouse, but not with the touchpad, could also be consistent with that - e.g. if the left-click switch was intermittently shorting generating a spurious press, actually holding it down will mean no spurious presses occur. Or if the cable has weakened internally, you might get an intermittent connection sometimes, and just moving it around might make it intermittent.

I’d suggest disconnecting the mouse and try using only the touchpad for a little while, or switch to a different mouse. You could also try using the mouse on another computer if you really want to confirm that it is the mouse.


Thanks gents.
Yes Jonathon there was a hardware problem with the mouse.
I swapped it out for another mouse as you said and also went with the trackpad only for a while. That simplified the confusing symptoms a lot, but, there remains erratic mouse function.


When using the trackpad only using Ubuntu’s Settings, Mouse & Touchpad test function, a tap on the trackpad would show as ‘Single click, primary button’, good.
But after repeating this test successful for several times - suddenly I notice the result displayed is “Single click, middle button.

I tried with PureOS Live Boot also with similar result.

1 Like

Thanks for the updates @SageOwl.

The remaining issue sounds like the touchpad may be registering extra fingers - the default behavior is a three-finger tap for middle click. For what it’s worth, I booted Ubuntu 22.04 live on my 15v4 and don’t have any problems with this, so it’s at least not an issue affecting all devices (probably not a kernel/firmware issue).

Try cleaning the touchpad. Residue or debris might cause spurious touches to be detected, especially when they seem to barely register like in this case.

Otherwise, please contact support@puri.sm to discuss options to replace the touchpad.

1 Like