Unable to access keyboard settings

So i needed to type the pipe key on a UK keyboard and had not yet seen the issue on the tracker telling you to remove the lines form /lib/udev/… as such i have just spent the afternoon buggering my librem v2’s keyboard settings, i have now edited the file but the issue has not been resolved presumably because running im-config loops and runs whenever i try to open keyboard settings. these are the messages i get

Current configuration for the input method:
 * Active configuration: default (normally missing)
 * Normal automatic choice: ibus (normally ibus or fcitx or uim)
 * Override rule: zh_CN,
 * Current override choice:  (en_US)
 * Current automatic choice: ibus
 * Number of valid choices: 3 (normally 1)
The override rule is defined in /etc/default/im-config.
The configuration set by im-config is activated by re-starting X.
Explicit selection is not required to enable the automatic configuration if the active one is default/auto/cjkv/missing.
  Available input methods: ibus fcitx xim
Unless you really need them all, please make sure to install only one input method tool.

Two options, ok or cancel so i click ok

Do you explicitly select the user configuration?

 * Select NO, if you do not wish to update it. (recommended)
 * Select YES, if you wish to update it.

Select No as its recommended

Keeping the user configuration /home/georgesykes/.xinputrc unchanged as default.
Automatic configuration selects: ibus
Intelligent Input Bus (IBus)
 * Required for all: ibus
 * Language specific input conversion support:
   * Japanese: ibus-mozc (best) or ibus-anthy or ibus-skk
   * Korean: ibus-hangul
   * Simplified Chinese: ibus-pinyin or ibus-sunpinyin or ibus-googlepinyin
   * Traditional Chinese: ibus-chewing
   * Thai: ibus-table-thai
   * Vietnamese: ibus-unikey or ibus-table-viqr
   * X Keyboard emulation: ibus-xkbc
   * Generic keyboard translation table: ibus-m17n or ibus-table* packages
 * Application platform support:
   * GNOME/GTK+: ibus-gtk and ibus-gtk3 (both)
   * KDE/Qt: ibus-qt4
   * Clutter: ibus-clutter
   * EMACS: ibus-el
If a daemon program for the previous configuration is re-started by the X session manager, you may need to kill it manually with kill(1).
See im-config(8) and /usr/share/doc/im-config/README.Debian.gz for more.

then when i try to open keyboard settings i get the same as before.

So far i have undone the changes i made to the various config files, reinstalled ibus and fctix have restarted once (will try again in a moment). Any suggestions?