'Unable to download updates from "odrs.gnome.org"' message

PureOS on Librem 13v3

I executed ‘apt full-upgrade’ from the command line. Everything seemed to be ok.

Unfortunately, when I now launch ‘Software’, I receive the message:

Unable to download updates from “odrs.gnome.org”: [/*/*/*/source/odrs/*] failed to download https://odrs.gnome.org/1.0/reviews/api/ratings: Cannot resolve hostname.

I see a similar message when I go to Extensions in ‘Tweaks.’

I can ping that host and I can access that path using PureBrowser. I guess a setting is awry, but i have not a clue where I should look. Any ideas?


Update: I should have added that when in ‘Tweaks’ and I click an extension, I get a blank window.

Additional observations:

When launching ‘Software’ a second time, I do not receive the message noted in my previous post. I can chose an application and see its information, unlike the first time through.

Then, when I go into Gnome Tweaks -> Extensions and double-click on any one, I do not get information on the chosen extension. I get the information of the last application I looked at in ‘Software’.

This message disappeared from both “Software” and “Tweaks” launches. I am uncertain if there is a connection, but, in investigating, I launched “Software” while not being connected to the Internet. Afterwards, I no longer saw these messages. I originally had only launched these after the update while connected.

This still occurs, but it is a very minor annoyance. (Again, if I have not launched “Software,” this screen is blank.)

It is not a show-stopper, but this is a more extensive problem for me than I thought. It affects Activities->Search, Tweaks->Extensions, and Software.

Actually, the “odrs” message only stopped appearing on the UI when launched. While debugging why the Applications Menu extension does not work (sigh), I encountered the same message in the Application log prefixed by “failed to call gs_plugin_refresh” and, at the end, “cannot reach destination.”

In addition, I have a similar “cannot connect” message regarding https://cdn.fwupd.org/downloads/firmware.xml.gz.asc.

I am connected to the Internet, and I can get to all these places manually with PureBrowser. There must be some other conduit that is broken, and I still do not understand how all the Gnome pieces fit together. (I am beginning to remember why I turned off the desktops on all those Linux systems with which I worked years ago. :wink: ) Any advice on where to look would be appreciated.

I apologize if I am not following the right etiquette by replying to my own replies, but it did not seem proper to keep editing the original post with new information.

I haven’t seen any error like this before, but have you done

sudo apt update
sudo apt upgrade

since initially doing sudo apt full-upgrade?

If something went wrong, you might also try any/all of the following

sudo apt update --fix-missing
sudo dpkg --configure -a
sudo apt install -f

1 Like

Thank you for responding.

I have done subsequent update/upgrades, including this morning’s. I tried your other command line suggestions, but everything looks clean.

It is frustrating because this all worked when I received my system; it was something that happened with that first update–900+ packages–that caused things to go awry.

I’m kinda grasping at straws here, but what is the content of your /etc/apt/sources.list file?
I have PureOS in a VM, and it can update just fine, and this is the content of my sources.list


# deb cdrom:[Debian GNU/Linux none _Green_ - Official Snapshot amd64 LIVE/INSTALL Binary 20180120-02:05]/ green main
# deb cdrom:[Debian GNU/Linux none _Green_ - Official Snapshot amd64 LIVE/INSTALL Binary 20180120-02:05]/ green main
# deb http://repo.pureos.net/pureos/ green main
# deb-src http://repo.pureos.net/pureos/ green main

#deb cdrom:[Debian GNU/Linux none _Green_ - Official Snapshot amd64 LIVE/INSTALL Binary 20180120-02:05]/ green main

deb http://repo.pureos.net/pureos/ green main
deb-src http://repo.pureos.net/pureos/ green main

deb https://repo.puri.sm/pureos/ green main

I notice this is slightly different from yours, but I have not changed it from what was delivered. I do not currently have the source repository. I did add another source to “Other Software” for a nautical chart application, but I did that long before all this went south. That package is also marked ‘hold,’ because it now requires libcurl4.

I have feeling there is some config file that is corrupt, but gnome seems to have so many interdependent parts, I am not sure what controls this. I plan to start getting source and looking to see where to go next.

I keep thinking this is related to gnome-tweaks. It appears to use a cached version of the extension information. As I mentioned it is blank if I have not accessed anything in Software, and it uses the last one if I have. The only thing that makes me think that is folly is that I see the same behavior with Activities->Search, but I am just learning. For the record, gnome-software is 3.28.0-1pureos1 and gnome-tweaks is 3.28.1-1.

Again, thanks for your suggestions. Any pointers are appreciated.

Hmm, your conclusions do seem likely, but I don’t know enough about what’s going on under the hood in GNOME to provide much additional help.

Out of curiosity, have you run
sudo apt autoremove and sudo apt autoclean at all?

Do they show anything suspicious?

Given what you’ve posted, I doubt they will, and it does seem like some weird config error somewhere, but since something with apt appears to have created the mess, I’m hoping apt can dig itself out.

Yes, I have run those commands. I do not see anything unusual. I’ll keep plugging away and, if I can figure this out, I’ll post it. Thanks.

Update: I think that part of the problem which prompted my original post, ie. the graphical message, is normal behavior. I tried a live version of a different debian-based linux and it did the same. I also renamed the gnome-software cache, and I could recreate the same message until Software refreshed. The blank/old cached details of the extension, however, is a problem for me. One thing I have noticed is that when I double-click an extension in Tweaks, I get the following messages in the Applications log.

I do not have enough experience to know if this is the cause of me not seeing details on the extension in Tweaks or if this is the effect. But, some part of Tweaks seems to “think” this is not a valid extension. Is the “user/*/…” pseudo-path the domain of shell extensions or is this manifested in some directory or link? Could the disconnect be there somewhere? (Alt-tab is clean. I have never touched it and it is not enabled; it is the Applications Menu that has me tearing what is left of my hair out.)

It hit me that the “user/*/…” path may be part of the organization on extensions.gnome.org. But, I also finally noticed that the uuid in the assertion error message from ‘Software’ has an underscore where I would have expected a ‘@’ character. I do not know if this is why there is an error or if the substitution is because ‘@’ is reserved in this context. When looking at the debug messages on Gnome Tweaks–not for this extensions panel but as it looks up enabled extensions–I always see '@'s in the URLs. I am crawling through the code now, but if someone familiar with gnome-software and gnome-tweaks knows, it would save this new user some time.

It appears someone else has seen the blank window problem with Gnome Tweaks on Ubuntu. There is not much information, e.g. versions, but the poster has links to some screen shots.

Update: It appears that the ‘_’ substitution for ‘@’ is not new in the scheme of things. It is made on line 91 in tweak_group_shell_extensions.py:

self.app_id = “user/*/extensions-web/shell-extension/” + uuid.replace(’@’, '’) + “/*”

So, I guess this issue is just a broken schema/path for me, and I have not made any headway in understanding it.

I am surprised that no one else is seeing this problem; I was able to reproduce it today on a live boot of Kali Linux 2018.2, also Gnome Tweaks 3.28.

Interesting. What did you do to reproduce it in the Kali image?

On Kali, I did not do anything special. I connected to the network and launched ‘Software’. That gave me the odrs message ‘Can’t resolve hostname.’ with which I started this thread. Once that cleared away after relaunch, I went into Gnome Tweaks->Extensions and double clicked Alternate-Tab. I got the blank screen and the assertion errors in the logs.

One thing that I found interesting on Kali is that there is no cached information under /root/.cache for gnome-software. That may be a clue. The same behavior could mean missing information for me too on PureOS. I did notice that Gnome Tweaks reorganized things a bit from 3.26, e.g. the extensions sub-directory is now shell-extensions. (I already tried a link but that failed.)

I do not want to get side-tracked with this, because this is a PureOS forum. I mentioned it and included the Ubuntu link because there might be something more here under certain circumstances.

Thanks for your continued interest.

Hmm. My main Linux laptop is inaccessible to me at the moment, but at least in a Fedora 28 VM I have, GNOME Software seems to work just fine, and /root/.cache is also empty.

I noticed there is a ~/.cache/gnome-software/odrs/ folder, which is populated with the review information (stored in a .json file) for applications you’ve viewed. For example, when I viewed “Scribus” in GNOME Software, it created ~/.cache/gnome-software/odrs/skribus.desktop.json

Deleting that odrs folder didn’t affect anything, though. It just stores viewed programs, but doesn’t have any config info in there, and it gets recreated upon reopening Software.

I would not normally expect gnome-software to cache in root, but rather in the user’s directory. When booting Kali Live, however, one appears to be the root user. That is why I looked there.

Yes, I have deleted the caches too and see them get recreated, though I never seen anything resembling an extension using an underscore instead of an @. That is probably a red herring, but until I can figure out how it is asking for the information, I am stuck.

I have a new, boot problem after today’s updates (sigh), so I am going to table this debugging for now. Thanks again for your time.

Another has opened a bug report on the problem with Gnome Tweaks->Extensions->Details here:

He included a video of the issue.

Xavier, who opened the original report in Gnome Tweaks, was able to get farther than I. He determined the problem was with Gnome Software and opened an issue. The details are in gitlab here.

1 Like

Thank you so much
“sudo apt update --fix-missing”
Fixed the error