Unable to install any software from the repo


#1

Just got my Librem 13 a few days ago and I’m having issues installing ANY software from the repo. No matter what I choose, I get an error message that the download failed. With some apps that appears immediately and others seem to start to install and fail at 35% or 85% complete with the same message that the download failed. I am not having any issue with my internet connection and I have tried on two different networks…

FYI, I am fairly new to linux and not a tech person so maybe I’m doing something wrong but I don’t think so as I have another laptop running mint and have had no issues installing software on that system.


#2

Have you ran the sudo apt update command? not sudo apt-get update - for some reasons this makes a difference and it caused similar errors to me when I installed the OS on a laptop.

I’m not super tech-savvy either but maybe my advice will come in handy.

p.s. before you do so, can you check if you can run the sudo apt-get upgrade command? In my case, I could not, before I ran the sudo apt update command. Cheers.


#3

Thanks!

Yes, I was able to run the sudo apt-get upgrade command first. Then I ran the sudo apt update command and now am able to install software.


#4

you’re welcome. I’m glad it helped.


#5

I’m relatively new to Linux as well, and this may be “the blind leading the blind” but I’m happy to help. So what I’ve learned to do is manually run updates in the Terminal every day when I log in.
First I run
sudo apt update
Then
sudo apt full-upgrade
If I see any option suggesting there are files that can be deleted, I’ll run
sudo apt autoremove


#6

Just received my Librem, same issue. I was getting unable to install - 404 - not found - when trying to install something from the Software app.
I have run both sudo apt update and sudo apt full-upgrade and now it’s ok.

This issue is not very pleasant on a new product and I hope Purism will fix it.