Unable to install gscan2pdf

We cannot install gscan2pdf from GNOME software manager or using apt because of unmet dependencies. For example:-

sudo apt -f -y install --install-recommends gscan2pdf


Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
gscan2pdf : Depends: libossp-uuid-perl but it is not installable or
Recommends: djvulibre-bin but it is not installable
libbit-vector-perl : Depends: perlapi-5.28.0
libfilesys-df-perl : Depends: perlapi-5.28.0
libimage-magick-q16-perl : Depends: perlapi-5.28.1
libimage-sane-perl : Depends: perlapi-5.28.0
libproc-processtable-perl : Depends: perlapi-5.28.1
E: Unable to correct problems, you have held broken packages.

It seems we already have the perl requirement satisfied though:-

And trying to satisfy the recommendation djvulibre-bin from a .deb package yields:-

djvulibre-bin : Depends: libdjvulibre21 (= but 3.5.28-2 is to be installed

Please help! :open_mouth:
Thanks. :+1:

? Mentioned command isn’t simple (--fix-broken isn’t necessary and --install-suggests would be the one to be used, if it makes any difference). Therefore please install needed package from the command line with:
sudo apt update
sudo apt install gscan2pdf

apt show gscan2pdf
Package: gscan2pdf
Version: 2.11.0-1
Priority: optional
Section: utils
Maintainer: Jeffrey Ratcliffe <jjr@debian.org>
Installed-Size: 2,308 kB
Depends: imagemagick, libgoocanvas2-perl, libconfig-general-perl (>= 2.40), libdate-calc-perl, libfilesys-df-perl, libgtk3-perl (>= 0.028), libgtk3-imageview-perl, libgtk3-simplelist-perl, libhtml-parser-perl, libimage-magick-perl, libimage-sane-perl, liblist-moreutils-perl, liblocale-codes-perl (>= 3.60), liblocale-gettext-perl (>= 1.05), liblog-log4perl-perl, libossp-uuid-perl | libdata-uuid-perl, libpdf-builder-perl, libproc-processtable-perl, libreadonly-perl, librsvg2-common, libset-intspan-perl (>= 1.10), libtiff-tools, libtry-tiny-perl, sane-utils (>= 1.0.17)
Recommends: xdg-utils, djvulibre-bin, pdftk, unpaper, tesseract-ocr | gocr | cuneiform
Homepage: http://gscan2pdf.sourceforge.net/

Thanks for the reply.
The use of --install-recommends was an attempt to get past where sudo apt install fails, both with the same error.
Unfortunately --install-suggests does not help either.

Here is another one, very important one (before proceeding toward …):
sudo apt update
sudo apt full-upgrade
sudo autoremove
sudo apt-get clean
sudo reboot

Now please install following dependencies (as nothing wrong within PureOS, and as following confirmed on my Librem 5):

sudo apt update
sudo apt install gir1.2-goocanvas-2.0 imagemagick-6-common libbit-vector-perl libcarp-clan-perl libclass-data-inheritable-perl libconfig-general-perl libdate-calc-perl libdevel-stacktrace-perl libexception-class-perl libexporter-tiny-perl libfilesys-df-perl libfont-ttf-perl libgoocanvas-2.0-9 libgoocanvas-2.0-common libgoocanvas2-perl libgtk3-imageview-perl libgtk3-simplelist-perl libheif1 libhtml-parser-perl libhtml-tagset-perl libimage-magick-perl libimage-magick-q16-perl libimage-sane-perl libio-string-perl liblist-moreutils-perl liblist-moreutils-xs-perl liblocale-codes-perl liblog-log4perl-perl liblqr-1-0 libmagickcore-6.q16-6 libossp-uuid-perl libossp-uuid16 libpdf-builder-perl libproc-processtable-perl libreadonly-perl libset-intspan-perl libtiff-tools libtry-tiny-perl liburi-perl

Above command do not include suggested neither recommended packages therefore please keep the next one as simple (recommending again) as needed (no additional “attempts”):

sudo apt install gscan2pdf

NOTE: only related/opposite option that apt incorporates is: --no-install-recommends which means: “Do not consider recommended packages as a dependency for installing.” This in vice versa means (and tells) to the apt to go ahead and install-recommends.