Unable to install


#1

Hello everyone,

I’ve been asked to reinstall my OS. I am trying to follow the install guide, but no matter if I let the installer delete and repartition either of my disks or manually partition them, following the instructions, I get the same error message.

Installation failed
Failed to run update-initramfs on the target
The exit code was 2

This goes for the bwin 128gb that came with the librem 15v3 and the samsung evo 970 nvme.

Anyone have any thoughts on what I can do to fix this?

Thanks!

PS - While I’m on the topic of reinstalls, I noticed that neither the manual partitioning guide nor the automated partitioning return the configuration to the OEM default, using an encrypted LVS volume with a root volume and a swap volume. Does anyone have a how-to on recreating that configuration?


#2

I’ve upgraded my coreboot to the most recent version, following the official guide and script. Same results.


#3

Booted from purism installer usb

  1. mkdir /mnt/root
  2. cryptsetup luksOpen /dev/sda3 root
  3. mount /dev/mapper/root /mnt/root
  4. mount /dev/sda1 /mnt/root/boot
  5. grub-install --boot-directory=/mnt/root/boot /dev/sda
  6. update-grub2

Rebooted; Hung on

SeaBIOS (version rel-1.11.0-0-g63451fc)
Booting from Hard Disk...
_

#4

You can use our OEM image for this: https://downloads.puri.sm/oem/gnome/2018-04-26/


#5

I’m left with the feeling that SeaBIOS is the problem. Can anyone help me put in grub as the coreboot payload and skip BIOS altogether?

I’ve verified that grub is installed on the disk and the boot partition is boot-able.

  • fdisk -l shows that sda1 is bootable
  • file -s /dev/sda shows me there’s an mbr
  • file -s /dev/sda1 shows me the UUID, which is present in /boot/grub/grub.cfg
  • dd bs=512 count=1 if=/dev/sda 2>/dev/null | strings|grep GRUB turns up the string GRUB

#6

Hi,

I’m using PureOS on non librem laptop and I had same error message in upgrade process. I was able to fix it by installing “busybox-initramfs”.


#7

Thanks, maybe I’ll give that a try. In the meantime, I’m running into issues, during the re-install, which are logged in /root/.cache/Calamares/Calamares/Calamares.log:

2018-05-14 - 20:22:44 [6]: Target cmd: ("update-initramfs", "-k", "all", "-c", "-t") 
2018-05-14 - 20:22:44 [6]: Target output:
 update-initramfs: Generating /boot/initrd.img-4.15.0-2-amd64
/usr/sbin/mkinitramfs: 64: .: Can't open /usr/share/initramfs-tools/hook-functions
update-initramfs: failed for /boot/initrd.img-4.15.0-2-amd64 with 2. 

Seems odd that a fresh install would be missing this directory.
When I chroot into the calamares temp directory, it certainly isn’t there:

root@pureos:/# ls -l /usr/share/initramfs-tools/
total 32
drwxr-xr-x  2 root root 4096 Apr 25 22:44 conf-hooks.d
drwxr-xr-x  2 root root 4096 Mar 21 20:07 conf.d
drwxr-xr-x  2 root root 4096 May 14 20:22 hooks
-rwxr-xr-x  1 root root 5960 Mar 21 19:56 init
-rw-r--r--  1 root root  357 Mar 21 19:56 modules
drwxr-xr-x  2 root root 4096 Mar 21 20:07 modules.d
drwxr-xr-x 10 root root 4096 May 14 20:21 scripts

Any insight into how this can be resolved?