Unable to load /dev/vmmon (vmware installation)

I am having considerable trouble getting vmware to function, although kernel headers installed fine. Has anyone had trouble installing the necessary kernel modules for vmware, specifically vmmmon and vmnet? After running the command “vmware-modconfig --console --install-all” the log shows virtual machine monitor (vmm) and virtual ethernet failed to start. Any help would be greatly appreciated, because I need this running for my job. thanks in advance

I believe my colleague already replied to you via email.

Yes he did respond but wasn’t familiar with vmware, and I was hoping someone here has steps to get it working, because I’m stuck at a certain point with the kernel modules. Hopefully someone on this forum has installed vmware and can assist me.

have you tried ? > https://communities.vmware.com/welcome

perhaps that’s the best way to find help regarding something that is PROPRIETARY :upside_down_face:

yes I’ve tried (exhaustively) vmware forums, as well as having years of experience installing it on various flavors of Linux. I only asked for help in regards to pureos because of the differences this operating system handles kernel module loading. I’m bringing it to this help forum in hopes someone has had my issue.

has someone from the vmware forums suggested that this is happening because of PureOS’s kernel module loading ? if that’s the case then that is a pretty weird way to complain since they are the ones who don’t play ball … i assume Debian is working as expected ?

I keep getting referenced to this or that from the vmware forums, but it keeps coming back to what makes pureos special, which I love by the way, but it makes for getting vmware to function difficult. I switched to virt-manager in the meantime, and while it works, it is missing some virtual cpu pass-through options that vmware has. yeah I have the latest pureos, debian buster I believe, and everything else works as expected. I know it has to do with pureboot I have running (librem 15v4) and the fact it isn’t UEFI. I tried a few workarounds, and got everything functioning aside from being able to load vmmon and vmnet, which are kernel modules. I would rather give up vmware than sacrifice the secure setup I have with pureboot, but was hoping there was a fix that I missed.

1 Like

i could ping somebody but i don’t want to abuse their kindness in this way …

no worries maybe another user will see this at some point but I’ll keep looking for a solution.