Unable to update the apt package cache

When running PureOS, I first found that, when I try to run an unknown command, instead of listing potential packages from the package sources, I get this:

Could not find the database of available applications, run update-command-not-found as root to fix this

When I run that command, however, nothing happens. Further, I notice when I run this:

apt-file find intltoolize

(Where “intltoolize” is a file I don’t have installed), I get this:

E: The cache is empty. You need to run “apt update” first

When I run sudo apt update, I get the following output:

Hit:1 http://repo.puri.sm/pureos green InRelease
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.

However, this doesn’t seem to make a difference - my apt cache remains empty. Do I need to add a different/additional source? What am I missing?

1 Like

You need to install package intltool which contains intltoolize file: sudo apt install intltool.

1 Like

Thanks, but that’s not really my problem, it’s just an example of a command that doesn’t work. :slight_smile: How do I get the apt cache to update, so that commands such as apt-file search <packagename> and update-command-not-found will actually work?

1 Like

Okay, I understand, I have the same problem here, even after running sudo apt-file update. Directory /var/lib/apt/lists is populated. I will report this to our tracker.

1 Like

Bug report is here for those who want to follow along: https://tracker.pureos.net/T155

1 Like