Unable to update/upgrade PureOS

I recently has to re-install PureOS Byzantium from my live CD,

>uname -r
5.10.0-5-amd64

however, when I try to update the repo sources,

> sudo apt udpate
Hit:1 https://repo.pureos.net/pureos byzantium InRelease
Hit:2 https://repo.pureos.net/pureos byzantium-security InRelease
Hit:3 https://repo.pureos.net/pureos byzantium-updates InRelease
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
All packages are up to date.

no packages found for update. Running,

>sudo apt upgrade
>sudo apt full-upgrade
>sudo apt dist-upgrade

all confirm that there are no packages for update.

If I try to install some new software,

>sudo apt install mariadb-server

I get a 404 error:

E: Failed to fetch https://repo.pureos.net/pureos/pool/main/m/mariadb-10.5/mariadb-server_10.5.9-1_all.deb 404 Not Found [IP: 138.201.228.45 443]

and indeed, there is no such version on the repository because the latest version of mariadb is 10.5.10-2 which is available but my system is not able to see it as the udpate process if not working.

Any idea how to force the udpate process?

1 Like

I found a way to solve this,

> sudo mv /etc/apt/sources.list ~
> sudo apt update
> sudo mv ~/sources.lst /etc/apt/
> sudo apt update

now works and finds all the packages that need to be udpated.

5 Likes

Thanks, I also had this issue on my new Librem 14. It was getting 404 errors on all the deb files. Checking the urls, the deb files were all a point release behind and your technique solved it.

1 Like

This also worked to solve the same issue on my Librem 5.

1 Like

thanks for the awesome informaton.

1 Like