Uninstalled ProtonVPN and Now Have No Internet

I tried installing and running ProtonVPN via flatpak. I was unable to get the VPN to connect so I uninstalled to try to tackle it on a future date.

After reboot, I’ve lost all internet access via both cellular and wifi. I’m assuming some settings got left behind that is preventing me from having internet access. Can someone please point me to some things I could check/reset?

I’ve only been using my L5 for a day and could easily reflash if needed but would prefer to try to learn how to fix this if possible.

Thank you in advance!

Update: I did verify that there is no VPN listed in network settings/VPN
Update 2: I tried navigating to google.com in Firefox with no luck. Pinging the address from my desktop, I tried navigating to in Firefox, still no luck. I think this is more than a DNS issue.

First step would be to check if connectivity is completely gone or if its just a dns problem. Can you open the terminal and “ping”?

1 Like

I am able to ping with roughly a 20ms response time.

Ok try and ping something by DNS name then “ping puri.sm”

1 Like

Ahhh, it might be dns. I can’t ping puri.sm or google.com. But I did ping which resolves to google.com and do get responses.

Found out the IP for puri.sm is and can also ping that successfully.

Ok, check out what your device has configured for is DNS server “cat /etc/resolve.conf”

1 Like

I’m not completely lost, thankfully. :slight_smile: Was already catting resolve.conf when you replied.

Lots of comments followed by:
nameserver ::1
search .


Well, as you can see you don’t have any nameserver configured for some reason. This should be received via DHCP from your router when you get your ip information. You can manually add your local dns server to temporarily get dns back if you edit that file as root, or add one in the gui through the settings app. I don’t know what the installation did to mangle that though unfortunately. Do the comments at the top still mention being managed by systemd-resolved?

1 Like

It does say that it’s managed by man:systemd-resolved(8) and that it’s a dynamic resolv.conf.

I’ve tried forgetting the wifi and re-adding it, that didn’t work. It’s almost like systemd-resolved.service(8) is broken. Is there a way to reset it or am I looking at reflashing?

I catted nsswitch.conf and the hosts line is:
files mdns4_minimal [NOTFOUND=return] dns myhostname

systemd-resolved is active by checking with systemctl

Finally, looking at resolv.conf, it’s linked to /run/systemd/resolve/resolv.conf. Is that correct?

I fixed it by creating a PureOS USB, booting into it, and re-flashing my phone.

I know it was brute force but the problem is solved now. :slight_smile:

Thank you very much for your help!!!

hah! Yeah if that is an option its always nice to have a clean slate :slight_smile:

1 Like

I had success installing ProtonVPN by installing the ProtonVPN-CLI version via command line.
It is then toggled On/Off in Settings/Network/VPN, or via CLI command.


For future reference, search is your friend. You can see that other users have had exactly the same problem e.g. Librem 5 - no internet connection after deleting the vpn connection and e.g. Lost internet connection

Nothing wrong with nameserver ::1 i.e. it may be completely legitimate and may work. But, here, yes, a symptom of ProtonVPN untidiness.

1 Like

Thanks! I did search but apparently my searching skills need improvement. :slight_smile:

1 Like

I had a similar problem on my Linux laptop.In my case pvpn-ipv6leak-protection was the culprit. It may be residual ipv6 leak protection.

nmcli connection show --active #to see if the problem shows up there
nmcli connection delete pvpn-ipv6leak-protection #The fix

As I recall, I located the fix on the protonvpn-cli GitHub site.