Librem 5 - no internet connection after deleting the vpn connection

I went in the menu --> setting --> network
and under the VPN voice, I deleted the VPN connection I had set up.

Since then, it has been unable to connect to the Internet.
Neither from mobile network, nor from WIFI. I tried to uninstall also the protonVPN but nothing has changed.
what can I do to solve this problem?


have a look at this this topic on the forum the Problem sounds quite similar just different librem device and I guess it’s probably also the DNS.
you could check that quite easily via the terminal by ping if that works you can be quite confident that it’s the DNS.

What do you see when you issue this command?
cat /etc/resolv.conf

Do not laugh, i would try a reboot. :slight_smile:

Also you could reconfigure your wlan (delete and add it again). However its just a suggest.

With amosbatto or Manuels hint, you can detect whats gone wrong and a contribution to the user experience, after delete or unset some VPN.

And i would add to check the route comment too:

$ route

Cause without a default route, your system did not know where to send packages to your Internet Gateaway.

1 Like

it show me this

Sorry but I’m a really basic linux user. I’m not very experienced, but i like to learn and understand.
To me looks like if there’s some option somewhere (but i have no idea of where) that say “connect to internet only if a VPN is on” or something like this.

output of the command:
ip route
default via de wwan0 proto static metric 1050 dev wwan0 proto kernel scope link src metric 1050

ping -c2
PING ( ) 56 (84) bytes of data.

— ping statistics —
2 packets transmitted, 0 recieved, 100% packet loss, time 1016ms

Absolutely. IT panacea.

I would also try using the kill switch to power cycle e.g. the WiFi.

@Prabhu Did you try the reboot?

OK, clearly broken - and exhibiting the same symptoms as in the other topic, which you should review.

I suggest pinging the specific host ( as requested.

I would also kill the modem and enable the WiFi - as that may be slightly easier to debug.

OK done, i killed the modem like @irvinewade told me, enabled the wifi and I runned the command:

echo -e 'nameserver\nnameserver' | sudo tee /etc/resolv.conf

than wifi desappeared… i rebooted and runned those command once again, this time the wifi didn’t desappeare, and internet came back!
I reinstalled protonVPN and reset the connection vith vpn. than I switched off the phone, i connected once again the modem and killed the wifi, switch on and it was connecting again like normal.

I would like to thank you all for the support @Manuel @amosbatto @Christal @irvinewade
problem solved


My two cents, but I don’t think this is gonna be a permanent fix. Unless you stopped using networkmanager (or configured it to never touch resolv.conf) the file will probably get overwritten. A stronger solution would be to configure all of this in NM config files. Also forcing DNS can interfere with MMS (some providers’ dns will return an internal address for the MMS gateway weither you use their DNS from their network, or a public one)

Yes - as it is supposed to.

I think there is a specific problem here when you have unclean exit scenarios with ProtonVPN. As long as you either don’t use ProtonVPN or use it cleanly, the file will be maintained properly.

The point of overwriting it manually is just in order to restore working DNS temporarily so that the ProtonVPN client can be re-installed.

1 Like

Oh ok I probably read the thread too fast. I had the same kind of problems with wireguard. what definitely fixed it was to make NM use systemd-resolved as a resolver. Since then, it has been working flawlessly

Yes, I personally prefer that. Then /etc/resolv.conf actually won’t be changing randomly and will instead always contain in my experience.