Unmet dependencies help

Thank you @Dwaff
Feels like a Sophie’s choice…
Is there a way not to give up PureOS?? and keep all the other or if I keep all the other dependencies I do not really have PureOS anyway…?

There is but it is convoluted and ugly:

  1. Prepare 32bit environment in a chroot and link it with your main system, (instructions here for pureOS amber and Debian buster pair).
  2. Install crossover via deb package inside a chroot (pulls in all the dependencies)
  3. Install crossover in a main system using manual installation script. (Download installer from codeweavers, choose option “Other linux not listed above” to obtain the installation script)

It used to work for me, but my trial period expired long ago, so can’t really help much more with it.

Good luck. :slight_smile:

I just received a Librem Mini V2 and out of the box I am unable to update software. I am getting “unable to download updates: The following packages have unmet dependencies:” error message.


1 Like

try this in a terminal:
sudo apt update
sudo apt upgrade

if you still have the error message, copy and paste it here, what you gave is not enough to understand what is going on


Yes, just adding to everything that @fralb5 kindly recommended:
sudo apt autoremove
sudo reboot


Thanks to fralb5 and Quarnero

1 Like

@mercatus did this solve all your issues?

Is there any issue with mixing apt update with the gnome software updates or will they work in harmony?

First, OS cannot work with the gnome-software and/or apt at the same time (one will lock another, especially if Software automatic updates not disabled). Let me think of them as that those are independent in what/how they perform. Here is GNOME official explanation on how Software works: “Software uses a plugin architecture to separate the frontend from the technologies that are used underneath.” Perhaps this options might be usable:
$ gnome-software --mode overview
$ gnome-software --mode installed
$ gnome-software --mode updated
$ gnome-software --mode updates

1 Like

To fully understand do you mean running either while the other is running - or do you mean running one one day, then a few days later running the other?

1 Like

I think that sounds like quite reasonable recommendation, coming basically from your side. I just do not feel comfortable with gnome-software (means nothing), therefore recommending running sudo apt update/upgrade at least once a week. In addition adding sudo apt-get clean (and autoclean) should help remove old update traces.

P.S. And what I actually meant is that PureOS cannot execute apt update while at the same time Software app is open. In short, just use one option at the time (result should be the same, especially when gnome-software fully operational).


It appears to have solved my issue. I did what fralb5 and Quarnero recommended. Then I ran the Software update. A few days later, there was another notice of a software update. I ran it. No issues.

1 Like

Hello @fralb5,

I used your recommendation regarding unmet dependencies error message- and it worked for 47 of 49 issues. With regard to OS updates and GStreamer Multimedia Codecs, I’m receiving this error message: Error calling StartServiceByName for org.freedesktop.fwupd: Failed to activate service 'org.freedesktop.fwupd": timed out

Any advice?

I also included the following per Quarnero:
sudo apt autoremove
sudo reboot

thank you

Any luck getting all your updates?

I recently upgraded from amber to byzantium, and am now struggling to clear out upgrades with unmet dependencies.

When I run sudo apt update then sudo apt upgrade the output ends with:

0 upgraded, 0 newly installed, 0 to remove and 722 not upgraded.

I then run sudo apt dist-upgrade in an attempt to resolve unmet dependencies, which returns an error:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Any advice on debugging and resolving this would be greatly appreciated :pray:

That problem is discussed a couple of times in these fora. Personally, I uninstalled that package when I upgraded from amber. I did not need -dev, and everything was fine after that.

PS. You may want to check out this thread. It is probably more appropriate for the problem you have, with a more recent post.

This is helpful. Thank you. I have been on Linux/PureOS for over a year now and did not realize this. It makes sense. I update using Terminal, and I think that the Software auto update has run in the background sometimes, sometimes causing an unmet dependency. I have now turned off automatic updates in the Software application. I will stay on top of updates manually. I still check for updates in the Software application as well, after I have updated in Terminal. It seems as though some of the applications I have installed get updated only through the Software application.

Is that correct then, that running apt update in Terminal and the Software application running auto update at the same time can cause unmet dependencies?

1 Like

Normally if they try to run at the same time, one of them will fail because the database will be locked. This happens to me on occasion during first boot because the software center checks for updates (even if it doesn’t install them automatically, it’ll still notify you that there are some available and so needs to run apt update) and is faster than me typing it out on the terminal.

I didn’t check this regularly but following scenario happens sometimes when you get (although automatic updates turned off and therefore very useful feature/reminder) this picture-in-picture screen (after just connected to the Internet):

Now you should directly execute: sudo apt upgrade. After this process finished please execute (check): sudo apt update and if there are still some package left that is still not upgraded: apt list --upgradable will help to locate this particular package. Afterwards executing another: sudo apt upgrade would be self-explanatory (confirming that not all of the installed software updates are auto-controlled from …).

Above probably refers to only few packages (but I cannot confirm this). My actual tip in this post would be to execute:sudo apt update regularly while even apt info gdebi tells us that: “apt does the same, but only for remote (http, ftp) located packages.

And, as I was unsure on what to answer (while not having installed plasma-discover nor using gnome-software regularly, although installed) so after several years I might install synaptic again (this time under Wayland): apt install --no-install-recommends synaptic (therefore cannot tell much about it at this point of time other that its GUI was/is informational/logical when particular application dependencies overview needed). Furthermore, aptitude is actually very fine tool too (sudo aptitude update does the same job, while sudo aptitude opens aptitude own GUI interface).

Thank you @Quarnero!

1 Like