Unmet dependencies help

How do i meet these dependencies???
sherab@sherab-librem13v4:~$ sudo apt install gtk+3.0 libwebkit2gtk-4.0 libusb-dev
[sudo] password for sherab:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘libgtk3.0-cil-dev’ for regex ‘gtk+3.0’
Note, selecting ‘python-wxgtk3.0-dbg’ for regex ‘gtk+3.0’
Note, selecting ‘python-wxgtk3.0-dev’ for regex ‘gtk+3.0’
Note, selecting ‘monodoc-gtk3.0-manual’ for regex ‘gtk+3.0’
Note, selecting ‘libwxgtk-media3.0-gtk3-0v5’ for regex ‘gtk+3.0’
Note, selecting ‘libgtk3.0-cil’ for regex ‘gtk+3.0’
Note, selecting ‘python-wxgtk3.0’ for regex ‘gtk+3.0’
Note, selecting ‘gir1.2-dbusmenu-gtk3-0.4’ for regex ‘gtk+3.0’
Note, selecting ‘libwxgtk3.0-gtk3-0v5’ for regex ‘gtk+3.0’
Note, selecting ‘libwxgtk3.0-0v5’ for regex ‘gtk+3.0’
Note, selecting ‘libwxgtk3.0-gtk3-dev’ for regex ‘gtk+3.0’
Note, selecting ‘libavahi-ui-gtk3-0’ for regex ‘gtk+3.0’
Note, selecting ‘libwxgtk3.0-dev’ for regex ‘gtk+3.0’
Note, selecting ‘libcanberra-gtk3-0’ for regex ‘gtk+3.0’
Note, selecting ‘python3-wxgtk3.0’ for regex ‘gtk+3.0’
Note, selecting ‘libwxgtk-webview3.0-gtk3-0v5’ for regex ‘gtk+3.0’
Note, selecting ‘libwxgtk3.0-0’ for regex ‘gtk+3.0’
Note, selecting ‘python2.7-wxgtk3.0’ for regex ‘gtk+3.0’
Note, selecting ‘libgwengui-gtk3-0’ for regex ‘gtk+3.0’
Note, selecting ‘python-wxgtk3.0’ instead of ‘python2.7-wxgtk3.0’
Note, selecting ‘libwebkit2gtk-4.0-37’ for regex ‘libwebkit2gtk-4.0’
Note, selecting ‘libwebkit2gtk-4.0-37-gtk2’ for regex ‘libwebkit2gtk-4.0’
Note, selecting ‘libwebkit2gtk-4.0-dev’ for regex ‘libwebkit2gtk-4.0’
Note, selecting ‘libwebkit2gtk-4.0-doc’ for regex ‘libwebkit2gtk-4.0’
libcanberra-gtk3-0 is already the newest version (0.30-7).
libcanberra-gtk3-0 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gsettings-desktop-schemas : Breaks: mutter (< 3.31.4) but 3.30.2-9~deb10u1 is to be installed
 libwxgtk3.0-dev : Depends: wx3.0-headers (= 3.0.4+dfsg-8) but 3.0.5.1+dfsg-2 is to be installed
                   Depends: libwxbase3.0-dev (= 3.0.4+dfsg-8) but 3.0.5.1+dfsg-2 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

This is because Debian packages (that you introduced for Crossover) are incompatible with PureOS packages. The somewhat easy options out of this:

  1. Delete Debian from sources.list (breaks Crossover)
  2. Abandon PureOS and switch to Debian (delete PureOS from sources.list and do apt-get update; apt-get dist-upgrade)

Thank you @Dwaff
Feels like a Sophie’s choice…
Is there a way not to give up PureOS?? and keep all the other or if I keep all the other dependencies I do not really have PureOS anyway…?

There is but it is convoluted and ugly:

  1. Prepare 32bit environment in a chroot and link it with your main system, (instructions here for pureOS amber and Debian buster pair).
  2. Install crossover via deb package inside a chroot (pulls in all the dependencies)
  3. Install crossover in a main system using manual installation script. (Download installer from codeweavers, choose option “Other linux not listed above” to obtain the installation script)

It used to work for me, but my trial period expired long ago, so can’t really help much more with it.

Good luck. :slight_smile: