Unmet dependencies on brand new Librem 14

I am really struggling to set up my new laptop. I went through the first time setup wizard. Then I resolved the “ERROR: Boot Hash Mismatch” issue through the help of Support (thank you). I then installed ProtonVPN. Then in terminal I ran “sudo apt update”. There were over 1,000 packages available for upgrade. So, I ran “sudo apt upgrade.” I was connected to ethernet, but it still took a while to perform all of those upgrades. I then added the Flathub repository and restarted.

Now the Librem 14 lingers on the “PureOS” screen during boot up for quite a while, maybe a minute or two, which it wasn’t doing before and which my 9 year old laptop running PureOS doesn’t do. Then when I enter my user password to login, it lingers on the login screen for quite a while also. Again, this is maybe for a minute or two, and it wasn’t doing this before and my 9 year old laptop doesn’t do this. I have ProtonVPN and the Flathub repository on my 9 year old laptop running PureOS.

Also, when opening Gnome-Software, I get an error at the top of the window. The updates tab is noting 2 available updates, “2” in a blue square. When I click on the Updates tab I get the following error:

Unable to download updates:

The following packages have unmet dependencies:

The 2 updates that are listed are:

OS Updates

GStreamer Multimedia Codecs

The Librem 14 also can no longer connect to the internet. Before it stopped being able to connect to the internet, when I ran “sudo apt update” it noted that 15 packages were available for upgrade. However, when I ran “sudo apt upgrade” it said 0 packages were upgraded and that 15 packages were “not upgraded.”

Please help me resolve this issue. I have a lot of questions about potential solutions to this issue. Just so you are aware, I have been using PureOS on my 9 year old laptop for, I would say, the last 6 to 9 months. That is about the extent of my Linux experience, and I’m not an “administrator” type power user on Mac or Windows either. I have tried to educate myself about Linux on the forums and through watching videos, but I know I have a lot more to learn. That old laptop and this new Librem 14 are my personal laptops. I have the following questions:

  1. What is the best way to get my laptop running smoothly? Should I reinstall the OS?

  2. If I put an ISO on a USB stick and reinstall the OS, will that affect the Librem Key and PureBoot? I know I would at least have to update checksums and sign all files in /boot per the instructions that Support emailed to me yesterday.

  3. Reinstalling the OS doesn’t touch the boot partition, correct?

  4. Is there anything that I lose from the OEM install of the OS when I reinstall the OS myself?

  5. Also, with each major upgrade of PureOS, would it be best to install the new OS from an ISO on a USB stick to avoid unmet dependencies?

I emailed Support, but I’m not sure that Support is available on the weekends. So, I’m also asking for help here. Thank you for your help. I’m trying very hard to get this laptop up and running. To say that I am frustrated would be a bit of an understatement.

This is still a thing? I thought this would have been fixed by now (received my laptop from the first batch). There is a dependency problem that requires an user to do a “full-upgrade” rather than normal upgrade of the system.

In your situation I would recommend just flashing an iso with Pure OS 10 and reinstalling as you haven’t done pretty much anything to the system. After reinstall of PureOS you should run sudo apt update && sudo apt full-upgrade. You could try sudo apt full-upgrade on your existing system as the upgradable packages are likely cached.

To your questions.

  1. You should first try just running sudo apt full-upgrade, if that doesn’t do anything I would suggest reinstall.
  2. That doesn’t affect LK, but PureBoot needs to be configured again (resigning boot files, updating checksums and setting default boot, these should be easy if you follow instructions).
  3. Reinstalling the OS usually results in a new boot partition. In your case a new boot partion will be created and thats why the boot files need to be resigned etc.
  4. Not 100% sure. If Purism ships with the ACPI driver in their install then it does, but in case they do installing that is easy. sudo apt install librem-ec-acpi-dkms
  5. Last time I did a reinstall of PureOS 10 (I think that was beta version then), that resulted in this type of behavior from apt.

Thank you for your reply. It would be nice if Purism pointed buyers of their laptop to some documentation, even a webpage. How is one to know that you need to do a “full-upgrade” on your new laptop, especially users new to Linux.

Now I can’t even get a live USB to boot. I get the following error when trying:

Failed to find file /boot/grub/()/casper/vmlinuz
!!! Failed to boot w/ options: PureOS Live [EFI/GRUB]elflkernel /boot/grub/()/casper/vmlinuzlinitrd /boot/grub/()/casper/initrd.imglappend boot=casper quiet splash
!!! Something failed during USB boot
New value of PCR[4]: long string of numbers and characters
!!! Starting recovery shell

Any idea how I correct this or get past this?

How did you create/flash the usb stick? Does it work on another computer?

It does work on another computer. However, I first tried creating it on Linux a few times. Each time Echer would get to the end and say Oops something went wrong. So, I used the same USB stick on a Mac and created the live USB with Echer no problem. I did have to log in as Administrator. So, maybe when I was trying on Linux I needed to somehow tell Linux to run Echer as root or something. I don’t know how to do that.

Maybe I need to start with a new USB stick and create a clean Live USB using my Mac. Maybe the Librem 14 will like that better?

Wait …
When I enter the PureBoot Boot Menu -> Options -> Boot Options -> USB boot I’m presented with three options:


I choose option 1. Then I’m presented with these five options:


I was choosing Option 3 and getting the error noted above. Support replied and let me know I should choose the first option. So I will try that and give another update. I do appreciate Support replying to me on the weekend!

I got the same discrepancies notice when I got my L14 a week ago. It said I had 40 some apps that needed up dated but I couldn’t update them. I didn’t try anything cause I didn’t know where to even begin, so I just emailed support directly I was given these instructions:

This is usually a glitch in the package management graphical interface application, to fix it please run the following commands in a terminal window:

sudo apt update
sudo apt full-upgrade

I typed in these two commands, lots of things downloaded, lots of task bars went from 0 to 100, I reset the computer and all the apps were up to date and I’ve since been able to perform app updates as needed. I have no idea why or how it worked - but it did!


Yeah, at the point I got stuck it wiped out my internet connection as well. So I couldn’t run those commands.

So …
I got the Live USB running. I installed PureOS using the Simple Install, as instructed by Support. I then, also as instructed by Support, immediately followed Support’s instructions to resign boot files. Here are those instructions:

  1. Restart (when you complete installation process)
  2. Wait for the system to ask you to insert your Librem Key, press ENTER (do not insert the Key yet)
  3. You will get into PureBoot menu, NOW insert BOTH your Librem Key and your Librem Vault (gold USB drive)
  4. Select Options → Update checksums and sign all files in /boot
  5. If the system asks you to “UNLOCK YOUR GPG CARD”, this means you need to type in your Librem Key USER PIN
  6. Default USER PIN is 123456 (if you haven’t changed it), type it in and press ENTER (there will be NO characters shown on the screen while typing your PIN, don’t let that confuse you)

I then restarted. Resigning did not work. Now, after resigning the boot files, when I restart the Librem 14 I get the PureBoot Boot Menu with an error and a yellow background. The error reads:

TOTP: 968806 | HOTP: Error checking code, Insert Librem Key and retry

I have retried. I get the same error. Can someone please tell me how to correct this?

This laptop is wearing me down. I’m so frustrated and tired. I spent a lot of money on this and in all of my years of computing I have never seen so many errors. ughh!!!

Going to:
Options -> TPM/TOTP/HOTP Options -> Generate new TOTP/HOTP secret

Hopefully, that is the last of my problems for a while.

Well I spent all weekend troubleshooting issues, eventually re-installing PureOS, troubleshooting and resolving an error checking OTP codes. My Librem 14 finally seemed ready to use. I performed sudo apt update, sudo apt upgrade, and sudo apt full-upgrade.

Then …I added the Flathub repository (which I have running on my 9 year old laptop running PureOS no problem). Here are the steps I used to install:

  1. Go to https://flatpak.org/setup/PureOS/ and click the Flathub repository file button
  2. Install the downloaded file: right-click -> Open With Software Install
  3. Then restart

This caused my system to boot slowly and to be completely unable to connect to the internet. So, now I am at the same point that I was at the beginning of the weekend! What a nightmare.

Does anyone know any way I can reverse out of this?

And, when (if) I get my Librem 14 working, does anyone know how to add the Flathub repository without making PureOS unusable?

That is really unfortunate. I can’t troubleshoot this without installing PureOS and trying to replicate your issue. This is likely an issue with PureOS.

I would recommend trying an another Distro to rule out possible hardware fault. PopOS is similar to PureOS (Debian/Ubuntu based etc.) but imo quite a bit more mature than PureOS.

Thank you @zenyatta. I probably should switch to PopOS but in that case I feel like I should have bought a System76 laptop. I’m going to keep struggling along for a while. I’m close to my breaking point, but not there yet.

Support pointed me to https://tracker.pureos.net/T1085. I followed the instructions there. It fixed the issue with my Librem 14 not connecting to the internet. However, I have no sound. I have emailed Support, again. If someone here has an idea on how to restore sound to a Librem 14 I’d appreciate it. Thank you in advance.

Sound is now working. The System Sounds in Settings was all the way down. That’s why changing the System Volume didn’t give me any feedback sound.

Now I’m wonder about the firewall since the instructions at https://tracker.pureos.net/T1085 had me purge gufw and ufw:

  1. Do I have a firewall?
  2. Is it safe for me to install the “Firewall Configuration” package from the PureOS repository? Or, should I avoid this to be on the safe side?

The nice thing about linux laptops is that it really doesn’t matter which distro you choose. Is your laptop still being slow?

  1. You do have a firewall and that can be configured via iptable commands or more easily via ufw/gufw (uncomplicated firewall). Although it seems that ufw/gufw version (x) on PureOS was the cause for network not working.
  2. That package seems to be for firewalld (correct me if I’m wrong), that is the default firewall for Rhel and Fedora distros. So no need to install that.

Even though IPtables provides basic rules for most needs, I would recommend watching that issue on the issue tracker and once fixed, install ufw and gufw back.

1 Like

On my Librem 14 with PureOS firewalld was installed by default. And indeed the firewall-config tool helped me to get some things working again (to be specific: avahi, zeroconf and pulseaudio sound via network).

UPDATE: After I got my internet working again from following the instructions at https://tracker.pureos.net/T1085 PureOS was loading websites slowly. So, I reinstalled PureOS. This time I avoided installing gufw. Also, now I know the correct way to add the Flathub repository, flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo without sudo in front.
So, right now PureOS on my Librem 14 is working well and I’m enjoying the laptop. Thank you for everyone’s help and for Support’s help.