Update on Librem 5 byzantium fails

The updates tab of my Librem 5 (which I flashed to byzantium) fails when I try to install the latest updates. The message is:

Unable to install updates: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark.pk_2dengine-2dquark.Code1: Prepared update not found: /var/lib/PackageKit/prepared-update.

The packages that are supposed to be updated on linux-image-5.13.0-1-librem5, linux-image-librem5, linux-libc-dev, and megapixels.

Anyone else seen this?

I see this on my Librem 14 as well for OS updates

So, I was having the trouble with the Updates tab on the PureOS store. Today I tried by ssh’ing in and doing it from the command line:

sudo apt-get update
sudo apt-get upgrade

and that worked. A lot of packages were updated. This is Byzantium BTW. Now there are many more packages available in the PureOS Store too.

Although Megapixels was updated, the pictures seen by the camera are way too dark, and this not in a dark environment. Does anyone know if there is a way to have the camera capture more light or something?

Update: I just discovered that I could click on the various metrics at the top of the picture view and adjust the values. I increased the gain to maximum and I was able to lighten things up enough to take a decent picture.


Yes, there is a bug in PureOS Store right now that can cause triggering the update to fail.

Executing pkcon update -d before clicking the “Restart & update” button should make it work. Upgrading with apt or apt-get instead is fine too (although in the future please use dist-upgrade or full-upgrade instead of just upgrade, as upgrade may miss some package transitions)

There’s a workaround for this issue already, so hopefully it hits the repos soon.