Update to PureOS 3

Hi. I tried to follow the instructions in the Purism Devlog #3 in order to update my PureOS-distribution.

Apparently, I managed to install pureos-minimal and pureos-standard, but pureos-desktop gives a problem with doc-base:

me@librem:~$ sudo apt install pureos-minimal pureos-standard pureos-desktop
Reading package lists… Done
Building dependency tree
Reading state information… Done
pureos-minimal is already the newest version (0.7).
pureos-standard is already the newest version (0.7).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pureos-desktop : Depends: doc-base but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have tried many things that had been suggested on various sites on the internet (like “sudo apt-get update”; “sudo apt-get ugrade”), but the problem remains.

Could it be that doc-base requires a (lower) version of perl-base (e.g. 5.22), while I have 5.24 installed? What would be the best way to resolve this?


Check what the doc-base requires to verify this.

Yyou can downgrade a package with:

sudo apt-get install pkg_name=pkg_version.


thanks - I needed to downgrade perl-base and also some other packages, and I managed to execute all the commands suggested in Devlog #3 without running into error messages etc.

Boot menu however still shows PureOS 2.1 - what did I miss?

I expected to be able to boot into the new version, much like when I upgraded Ubuntu from 14.04 to 16.04…


Boot menu however still shows PureOS 2.1 – what did I miss?

That’s why it’s still alpha. :slight_smile: We still need to work these details.

I expected to be able to boot into the new version, much like when I upgraded Ubuntu from 14.04 to 16.04…

I don’t understand, you booted successfully or not?

Anyway, if you come across a bug, we would appreciated very much to report it to our tracker: https://tracker.puri.sm/


yes, I booted with success, but it doesn’t seem like anything changed - still looks pretty much like PureOS 2.1 to me.

I was expecting after the upgrade to have a new entry in the boot-menu with PureOS 3.0.

Don’t know if this is a bug, or if I missed something in the upgrade process (what does the line sudo > /etc/apt/sources.list in Devlog #3 do?).

But the system is still working (as it was before).
So no harm done…

New software (Like GNOME) in PureOS 3 mostly brings “under the hood” changes: bug fixes, performance improvements. But still, did you add new repo as explained here: https://puri.sm/posts/purism-devlog-3/

Hi Mladen,
this is how my /etc/apt/sources.list looks like (somewhere it was suggested to add also the deb-src, so I put it).

deb http://repo.puri.sm/pureos/ green main
deb-src http://repo.puri.sm/pureos/ green main

I just did another “sudo apt update && sudo apt dist-upgrade”, which finished without problems.

But how would I know that I run PureOS 3? I tried the following commands:

me@librem:~$ uname -a
Linux librem 4.7.0-1-amd64 #1 SMP Debian 4.7.8-1 (2016-10-19) x86_64 GNU/Linux

me@librem:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux testing/unstable
Release: testing/unstable
Codename: n/a

me@librem:~$ cat /etc/*release
NAME=“PureOS GNU/Linux”



This is definitely PureOS 3, but yes, some details like labels are missing (that’s why its’s still in alpha).


then everything is fine - at least so far everything is working as before for me. Apparently the changes are really under the hood.