Updated today , now phone won't turn on/start up

Did the update today now the phone won’t turn on or start up. Guess I have a nice paperweight now! Lol

What LED activity, if any?

What troubleshooting steps have you tried?

Have you contacted Purism support?

Green light comes on for a few seconds then changes to a red light for a few seconds with an occasional yellow/green light. Nothing comes up on screen. What troubleshooting should I do? I am a textbook newbie.
Haven’t contacted support yet.

And then? No LED at all?

I put the battery back in and plugged in the power cord. Now the green light blinks on and off but nothing comes up on the screen.

Now it’s going from green to a red/yellow color light and then back to a green blinking light.

Try following procedure here: https://docs.puri.sm/Librem_5/Troubleshooting/Charging.html#librem-5-troubleshooting-recharging

I have to hit the hay now but I will try this tomorrow and post back here what happens. This forum is so cool! Thanks for all your help too!

Sounds like just a deeply discharged battery. Should be a matter of giving it some time to charge before attempting to turn it on.


Battery was in the high 90’s of charge before the update. The update drained the battery? It was plugged in to power while downloading/updating. How did this happen?

Because it depends on what you did before of the update, so just reinstall linux (not gnu) to may fix or use uart.

When I’m not using the phone(which is just charging/updating) , I remove the battery.

Even if you not doing anything before, the system can be broke when upgrading, so this a normal behaviour in gnu+linux some times. So if you have an uart you can see what is going on.

I started the reset process that irvinewade posted. The light was red for maybe 20-30 mins. and now went off. I’m letting it charge for awhile , will try turning it on a bit later.

I guess that linux it broke. But take easy you can fix it reinstall linux or reinstalling all the gnu system.

I think that means: It was close to 100% charged before you started the reset process. In the 20-30 minutes, it reached full charge. The red LED goes off because it’s not charging any more (because the battery is fully charged). You should at that point take it off mains power (as a generic point about care and feeding of a Lithium battery) - even if you try turning it on only after some delay.

I don’t think that it’s a good idea to remove the battery routinely e.g. just because you are not using the phone.

1 Like

I’m still fiddling with the phone , haven’t gotten it to turn on yet. Yeah I’ll leave the battery in the phone from now on. I’ll post when I get it going.

Within this thread I found solution for your specific troubles, as you described those:

1 Like

Probably won’t help, as he was already taking out the battery physically, achieving the same. From that same thread:

But probably still worth a try. Can’t hurt.

1 Like

I tried all the suggestions. It will not start up. Light goes from green to yellow to red and phone vibrates about every 15 sec.The batteries are both in the high 90% of full charge because that’s what they show as when I put them into my other L5( not Byzantium) phone. Spare parts now it is.