Updating 3rd party apps help

Hey everyone,

I finally made the move from apple to Linux and am very happy about that, but O man is it an adjustment. With that being said, today I tried to update an app and couldn’t get it to work. A few months ago I found a thread on here how to launch apps but I can’t find it. Could anyway help me with the basics of how to launch and update apps?

Today I tried extracting the deb and zip files but couldn’t get it to work. Also tried using terminal commands and couldn’t get that to work wither.

Anyway help would be much appreciated!


What OS, what app, how did you install it, and what have you already done?

1 Like

Thanks for your reply.

I’m running pureOS the app is an audio editing program. I already installed the app and it’s running fine but it just needs to be updated. As far as initial install, I actually can’t remember exactly how I did it a few months ago, unfortunately.

Congrats! I remember when I made the switch it is a learning curve but with time you will definitely get there. If you’re using PureOS one way is through “Software” or you can in the terminal do “sudo apt-get update” then “sudo apt-get upgrade”. With Debs you need to run dpkg -i then the package name to install usually the apps would be found in the launcher. For zips just extract them then through the terminal do “ls” to find where you are then “cd” to the location and use “./ + program_name.sh”. Hope this helps.

If you have the .deb for the new version, you can install it by typing sudo dpkg -i name-of-file.deb. It may then complain about dependencies, but we can burn that bridge when we get there.

If you got it from Software or by using apt or apt-get, then you’ll either have to wait until the repo’s version gets updated or replace it with the newer .deb.

Thanks so much, Brandon! Really appreciate this, it helps a lot. tried in the terminal and thought it worked but app still says it needs an update…so, I’ll just go through again and make sure I got everything right. Wish you a nice day and thanks again!

Of course. If you’re still having issues paste a screenshot in.

Thanks a lot. I just tried this and got this error message. “cannot access archive” No such file or directory. Strange because I just downloaded the deb. Do you know what this could be? Surely user error. Arrgh.

You can also use GDebi, a small graphic utility for installing downloaded .deb packages. (Works as a command line utility, too.) You can find it in the Software store, or just install it in terminal with sudo apt install gdebi. Once it’s installed, and you have associated it to .deb files as the default program, you’ll be able to just double-click the .deb to trigger installation.

I found this little tutorial for you:

(Note that both PureOS and Ubuntu are derivatives of Debian, which is why these actions and apps all work on any of these Linux distros. And I don’t agree with his recommendation to “stop using Software Center.”)

You probably know this already, but always verify the checksum of packages downloaded from websites.

Welcome to Linux! :slightly_smiling_face:

1 Like

Did you change directory to the folder where the .deb is? When you first open the terminal, you are in your Home directory, i.e. the folder named as your user name. If your downloaded .deb is in Downloads, you have to change to the Downloads directory by typing cd Downloads at the command prompt. Then and only then can you access any file that is contained in Downloads. (All this stuff is simply the command line equivalent of pointing and clicking your way around the file explorer graphic interface. Every GUI action has an equivalent command line action, in other words. More or less, anyway.)
Check out this easy introduction to some terminal commands:

hello and welcome @Scott3 !

please see this > https://explainshell.com/ < for explanations about what you are typing into your CLI (command-line-interface)

there are numerous shells you can use on GNU/Linux NOT ONLY BASH (Bourne-again-shell) !!!

1 Like

thanks a lot, Brandon. Got it all sorted, thanks for your help.

thanks a lot reC, I appreciate it. Got everything sorted.

Thanks a lot, amarok, I appreciate that.

1 Like