US T-Mobile settings for data and MMS

Hello Everyone,
I am posting here the settings that I used to have both mobile data and MMS working on a Librem 5 with a T-Mobile sim card.

In Settings -> Mobile

  • Mobile Data: On
  • Network Mode: 2G, 3G, 4G (Preferred)
  • Network: T-Mobile (setting is Automatic, it will find T-Mobile for you)
  • Access Point Names: The default was named “Broadband” with the APN “mobilenet”. MMS in Chatty would not work with this setting. Following a clue in another post, I added a new access point (press the + sign in the upper right) and added an APN with Name “T-Mobile”, APN “”, and no username or password. Select that Access Point

In Chatty -> Preferences -> Protocol Settings -> SMS and MMS Settings

Once I did these things, MMS messages that I had tried to send previously actually sent, and I was able to receive MMS with photos shown in-line.

I am REALLY HAPPY that MMS is working for me now!