USB 3 not working

Could you check your coreboot version, please? You can do it using dmidecode.

Vendor: coreboot
Version: 4.6-a86d1b-Purism-5

Version: 4.6-a86d1b-Purism-5

I just run the script to flash the newest coreboot (non ME normalization). But it is already the newest version, so no changes have been done and the problem still exists.

What do you mean by “USB3 ports don’t work” ? Do you mean that the ports work but only provide USB2 speeds? or they don’t work at all (nothing is recognized) or are you talking about USB type C and HDMI? Because the USB-C port does not support HDMI output as far as I know.
As for USB3, which ports exactly did you test and which ones work and which don’t ? I know that if you flashed the Librem 13 v2 image on a Librem 15 v3 machine, the top-left USB port will not work. Is that what happened ? Can you use ‘dmidecode’ to make sure the machine is identified as Librem 15 v3 ?
Also, why mention Fedora, is it because you noticed the problem when trying the USB key with fedora, or because it’s not working on fedora (but was working fine on PureOS) ?

Hi Kakaroto,
Thanks for your reply. I will try to answer all your questions.

  1. Yes it is a Librem 15 v3, tested with dmidecode

  2. The Librem 15 v3 has two USB3 ports on the right side. I have tested both ports with 2 different devices (USB 3 Stick, USB 3 HDD). It looks like they even don`t have power. They are like deth. But this devices work fine on the USB 2 ports on the left side of the notebook.

  3. USB C and HDMI are two different ports on the right side of the notebook. Because of lack of devices, I wasn`t able to test them right now.

  4. The main reason to switch to fedora so quickly, was that the browser was unuseable. I couldnt do search, except with google search page. I tried to install another browser (firefox, chrome) but purebrowser blocked everything from different sources. This didnt change after deactivating the two security apps installed. I use fedora for 10+ years and tried a lot of distributions, but always came back to fedora very quickly.

  5. In the pre installed PureOS version bluetooth was not supported. I found out later with the newest Live-PureOS-8-Beta1, that it works fine now. But browser still didn`t work for me, or I was too stupid to figure out.

  6. I love the build quality of the notebook. The battery-live is amazing. It is very quiet most time. The hardware-switches are in a good place, but feel a little cheap. The keyboard is not as good as the ones from macbooks, but I still like it and it has a num-block, great. Holy cow, just tested the speakers and they sound really great, much better then anything else i heard in a notebook. What I love about the display is that it is non-glare, and seams to be very bright. The view angles are not so good, which can be good in public places. Contrast seams to be very low, I have to see, if I an adjust a little. I will use it for photography, so I will test it more later.

Ok, lets fix this USB 3 problem. If it is a Librem 15v3 problem, then there must be others with the same problem. If Im the only one, it could be a cable or a non working part. I will open it as soon as I have a fitting screwdriver. It could be a coreboot problem as well.

Help and advice is welcome…

Ya, I had the same issue with my librem 15v3 and couldn;t get iceweasel to work either, so installed Firefox instead from binaries downloaded using another computer altogether and transferred using a usd key, Here is my post on my initial adventures with my Librem which you might find useful.

Thanks for your reply vrata, a lot of interesting and useful information on your post.

1 Like
  1. ok
  2. usb3 ports are directly on the motherboard (usb2 are using a flex cable to a daughter board), so I’m surprised that usb3 doesn’t work instead of usb2.
  3. ah ok. Unrelated then.
  4. ok, but usb3 wasn’t working on both pureos and fedora?
  5. I’m surprised bluetooth work in pureos, there’s no free driver. cc @zlatan-todoric ?

I just tested my Librem 15 v3 again with the same coreboot image and I tested all 4 USB ports and they work fine. If you can confirm it’s not a problem with the usb device itself (probably not since it works on usb2) and that it’s not a software problem (I tested on PureOS, maybe there’s a bug in the fedora build?). Then I would assume this to be a hardware issue. Probably caused by the USB3 power rail before disconnected or something like that (and I just checked the schematic, both usb3 ports are on the same power rail, the USB-C one is on a different rail though).
Once you can confirm that it is a hardware issue, I suggest an RMA with @mladen

1 Like

Hi Kakaroto

Thanks for testing and confirm that USB 3 works on your machine.

  1. Yes, I found out after opening the back yesterday to see if I could see some detached cables.

  2. Right, USB3 doesn`t work on PureOS neither on Fedora

USB 3 Support is part of the Linux Kernel and should work in any modern Linux Distribution. I just tested the devices on an other fedora 26 machine with USB 3 ports and everything works as supposed. So its for sure not a Software bug neither a device problem. Since you tested on the same coreboot version, it`s neither a bug in coreboot. So the only left possibility is a broken mainboard, at least in my opinion.

  1. Download the newest PureOS 8 beta 1, its a live image, put it on a USB-Stick and see how it works without installatione.

Fedora is also shipped with only free software. I didnt have to install any driver. So I believe its part of the newest Linux Kernel. That`s why it works in Fedora 26 and PureOS 8

Hi Mladen

Can you read my last post please USB 3 not working. I have done a bunch of testing and I`m pretty sure the mainboard is broken. Can you send me a new one asap? Or how would you like to fix it?

Thanks in advanced for your support and greetings, Marc


We are investigating this, you will be contacted in the next few hours.

If you need logs let me know. Can you send me a link to download the original purism OS, which was on the notebook? I only can find version 8 beta 1. I want to make sure, its not a kernel bug. If you need more information from my site, let me know.

Hi Mladen

Do you have any news? Can I help with logs or what ever?

Haven’t I contacted you via mail already? I’ll contact you again, I apologize for this.

I’m not 100% sure why it worked, but after I added pci=nomsi to my boot parameters (via GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub) my USB 3.0 worked fine on my Arch Linux install.

Here’s the post that led me to try it:

1 Like

That’s strange, but I am glad it worked.

Hey aarmea

Thanks for your input. I tried this with no success. I have to say, that my USB 3 ports have no current at all.

My new Librem 15 v3 has the same issue. 2x USB3 ports on the right side not working at all. Not sure on the USB C, as I have nothing to test, HDMI works fine, as do USB2 on the left.

As a non-tech person, and new to linux, I need very simple instruction if I’m to work this out without apoplexy :grin:

It might be that the wrong Coreboot image was flashed to it: for the Librem 13v2, instead of Librem 15v3. Trying flashing the latest image, and specify that you want it for the Librem 15v3 specifically. I had this same problem, too.

Brand new, with TPM, so it’s definitely new new. Does that seem even remotely possible?

New: USB C is powered too, so it’s just the USB3’s that are dead.

If the issue is as you suggest, how would I go about the fix? I’ve just spent a week getting it set up to my satisfaction, loading all of my stuff on in :expressionless:

edit: I missed that you stated L_13_ v2 not 15. hmm. Can I check somehow?