USB-C/Docking Station Monitor for Qubes

I have a Baseus docking station that I purchased from ThinkPenguin. Fantastic device and works great with other versions of Linux without any additional drivers. I have been able to get the majority of the devices attached to the docking station working in Qubues 4.0.4 by opting to attach them directly to dom0 (yes, I know about the security risks). All except the monitor. Anyone crack this particular nut? Thanks!

Same issue.

I’m guessing by what you wrote you are using the USB cube. I initially installed without the USB qube and monitor worked fine. Once I setup the qvm-usb it stopped working.

I ended up having to connect the monitor directly to the HDMI port.

I have installed with and without the USB-VM. Same result.

For what it’s worth - I solve the problem by removing the docking station and using a HDIC to USB-C cable. I then just used a dumb USB hub for the remaining USB-B standard devices. Tout va bien maintenant.

Follow up here. Same hardware model different location - and it works. So I believe the issue is with the device itself and not the L14.